[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cifs password length?



On Sunday 14 January 2007 19:16, Craig White wrote:
>On Sun, 2007-01-14 at 17:12 -0500, Gene Heskett wrote:
>> On Sunday 14 January 2007 13:44, Craig White wrote:
>> >On Sat, 2007-01-13 at 20:48 -0500, Gene Heskett wrote:
>> >> On Saturday 13 January 2007 16:12, Craig White wrote:
>> >> [...]
>> >>
>> >> >----
>> >> >If you are speaking of password entries in /etc/samba/smbpasswd,
>> >> > those are the already hashed password using standard Windows NT
>> >> > hash algorithm.
>> >> >
>> >> >If you want to set a password for say, user gene...
>> >> >
>> >> >smbpasswd gene
>> >> >(it prompts you to enter a password)
>> >> >
>> >> >this is then 'hashed' and written to /etc/samba/smbpasswd
>> >> >
>> >> >Craig
>> >>
>> >> Thanks Craig.
>> >>
>> >> I added gene to smbusers, which looked ok, and I hoped that would
>> >> stop smbpasswd from complaining about a non-existent user, but it
>> >> didn't.
>> >>
>> >> And it still won't set a passwd hash into the smbpasswd file which
>> >> is currently 0600 and owned by root, and zero bytes long.  And I
>> >> was doing that as root of course...
>> >
>> >----
>> >a samba user - say 'gene' must also be a Linux user too.
>>
>> gene is, albeit not a frequent login, usually via su.
>>
>> >there are many different password db systems that can be used for
>> > samba but /etc/samba/smbpasswd is the default if not specified
>> > otherwise. You may wish to check what you have set in smb.conf
>> >
>> ># testparm -sv |grep passdb
>>
>> Interesting Craig.
>>
>> After processing 3 sections, no errors shown,
>> Server role: ROLE_STANDALONE
>> 	passdb backend = smbpasswd
>> 	passdb expand explicit = no
>>
>> But I'm not 100% sure what that's trying to tell me.
>
>----
>I'm not 100% sure what that's trying to tell you either but I am
>gathering that you haven't 'added' the user gene to smbpasswd so trying
>to set a password for a non-existent user isn't going to work.
>
>Assuming that the user 'gene' is a user in /etc/passwd...
>
>smbpasswd -a gene # add user gene
>                  # you will be prompted for a password for this user
>                  # the results (user/password) will be added to
>                  # /etc/samba/smbpasswd
>Craig

Bingo!  Give that man a beer.  That *was* the magic twanger.

I had just booted it up, saw the wireless network start during the boot, 
and then be torn down by NetworkManager. A network restart brought it 
back, then I stopped NetworkManager and it was taken down.  That was the 
last straw with this wannabe network tool, its stopped and off, and will 
be nuked the next time I run yumex, the network restarted and everything 
it working except samba, I haven't tried to mount it yet.  But as you 
said, that smbpasswd file was where the name was missing.

Now I can't mount it because the lappy isn't at the address in the hosts 
file, thanks to dhcp, but I'd think that if dhcpd in the dd-wrt I'm 
using, has accepted a request from diablo.coyote.den, and assigned it an 
address of 192.168.71.104, that its own dns should have kept track of 
that so it could resolve requests for that machine.  I thought I had it 
configured, but apparently not well enough.  So I can either go back to 
fixed addressing, or fix the dns.  Study time, again..

Thanks Craig.  That's one more problem solved.

-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Yahoo.com and AOL/TW attorneys please note, additions to the above
message by Gene Heskett are:
Copyright 2007 by Maurice Eugene Heskett, all rights reserved.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]