[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Azureus crashes





on 01/17/2007 12:29 AM oleksandr korneta wrote:


on 01/12/2007 11:43 AM Paul Smith wrote:
On 12/28/06, Paul Smith <phhs80 gmail com> wrote:
Azureus crashes with the following message:

$ azureus
changeLocale: *Default Language* != English (United States). Searching
without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United
States)' (en_US), using 'English (default)'
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  Internal Error (53484152454432554E54494D450E43505001A3), pid=3248,
tid=3086011264
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_06-b05 mixed mode, sharing)
# An error report file with more information is saved as hs_err_pid3248.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
/usr/bin/azureus: line 18:  3248 Aborted
LD_LIBRARY_PATH=/usr/lib/eclipse:/usr/lib
CLASSPATH=/usr/lib/eclipse/swt-gtk-3.2.jar:`build-classpath bcprov
jakarta-commons-cli log4j gtk2.8
glib0.2`:/usr/share/azureus/Azureus2.jar java
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dazureus.install.path=$APPDIR org.gudy.azureus2.ui.swt.Main "$@"
$

Any ideas?
The problem disappears after updating Java (update 10).
mine crashes with another exception

$ azureus
Exception in thread "main" java.lang.NoClassDefFoundError: org/bouncycastle/jce/spec/ECParameterSpec at com.aelitis.azureus.core.security.impl.CryptoManagerImpl.<init>(CryptoManagerImpl.java:75) at com.aelitis.azureus.core.security.impl.CryptoManagerImpl.getSingleton(CryptoManagerImpl.java:60) at com.aelitis.azureus.core.security.CryptoManagerFactory.getSingleton(CryptoManagerFactory.java:33) at com.aelitis.azureus.core.impl.AzureusCoreImpl.<init>(AzureusCoreImpl.java:155) at com.aelitis.azureus.core.impl.AzureusCoreImpl.create(AzureusCoreImpl.java:92) at com.aelitis.azureus.core.AzureusCoreFactory.create(AzureusCoreFactory.java:46)
         at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:143)
         at org.gudy.azureus2.ui.swt.Main.main(Main.java:162)

I saw the hints on some forums that installing the original builds from azureus website should solve the problem, didn't try yet though.

just tried. It does work actually with original build.


--
regards,
Oleksandr Korneta

/The nice thing about standards is that there are so many to choose from./


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]