[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cant mount second drive



On Fri, 2007-01-19 at 11:11 -0800, Rick Stevens wrote:

> Oh, and have you tried "vgsplit NewVolGroupName VolGroup00 /dev/hdb1" to
> simply move the /dev/hdb1 PV from "VolGroup00" to "NewVolGroupName"?
> 
> In fact, you might try:
> 
> 	vgsplit -v --test NewVolGroupName VolGroup00 /dev/hdb1
> 
> to see what it'd do first.  It it looks like what you want, then take
> off the "--test" and give it a whirl.

i tried that but i'm getting this:

[root localhost ~]# vgsplit -v --test VolGroup01 VolGroup00 /dev/hdb2
  Test mode: Metadata will NOT be updated.
    Checking for volume group "VolGroup01"
  /dev/hdc: open failed: No medium found
  Attempt to close device '/dev/hdc' which is not open.
    Wiping cache of LVM-capable devices
  WARNING: Duplicate VG name VolGroup00: Existing
4O0f0O-fFa4-6Qfo-KRBh-knvO-WYsC-v3uVHK (created here) takes precedence
over CifEpP-vH2h-fb16-XERE-EmJA-HqWu-pDkiUW
  Volume group "VolGroup01" doesn't exist
    Test mode: Wiping internal cache
    Wiping internal VG cache

so obviously i can not do this because of the duplicate names. or at
least that's what i'm reading into the output. am i missing something?

> ----------------------------------------------------------------------
> - Rick Stevens, Senior Systems Engineer     rstevens vitalstream com -
> - VitalStream, Inc.                       http://www.vitalstream.com -
> -                                                                    -
> -  You know the old saying--any technology sufficiently advanced is  -
> -               indistinguishable from a Perl script                 -
> -                                 --Programming Perl, 2nd Edition    -
> ----------------------------------------------------------------------
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]