[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: remove duplicate rpm



Yuandan Zhang wrote:
hi,
I had problem with yum (update oor check-update etc). it always showed hanging there for ever or segfault. I followed suggestions from this list, found there were two scim-libs rpms.

I did following:

yum remove  scim-libs-1.4.4-9.4.fc5.

rm -f /var/lib/rpm/__db*
rpm --rebuilddb
yum update

after that it still shows two scim-libs rpm

removing shows error as follows.


[root zhang ]# rpm -q scim-libs
scim-libs-1.4.4-9.4.fc5
scim-libs-1.4.4-9.8.fc5
[root zhang ]# rpm -e  scim-libs-1.4.4-9.4.fc5
/usr/bin/update-gtk-immodules: line 27: /etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules: No such file or directory
error: %postun(scim-libs-1.4.4-9.4.fc5.i386) scriptlet failed, exit status 1

If you are running a x86_64 system make sure that these are indeed duplicate packages and not just multi lib ones. Details at http://fedora.redhat.com/docs/release-notes/fc6/en_US/sn-ArchSpecific.html#id2977158. If these are confirmed to to be duplicate, you can do

# rpm -e --noscripts <package>

Rahul


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]