[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Where's /dev/sda4?





On 1/24/07, David Levner <davidlevner yahoo com> wrote:
On Tue, 2007-01-23 at 17:40 -0800, David Levner wrote:
> I have Fedora Core 5 running on a Lenovo T60. I'm trying to access a
> zip drive, and the instructions from Iomega's web site say to use a
> mount command with the device /dev/sda4. But I don't see /dev/sda4 on
> my system.

Thanks to David Chipman and Tim for their suggestions, I've been able to make some progress. Using David's suggestion (dmesg | grep sd), I found that the device I'm looking for is /dev/sdb. I found messages like these:

sdb: Spinning up disk......ready
SCSI device sdb: 489532 512-byte hdwr sectors (251 MB)
sdb: Write Protect is off
sdb: Mode Sense: 45 00 10 08
sdb: assuming drive cache: write through
sdb:<5>audit( 1169598497.790:214): avc:  granted { execmem } for pid=2632 comm="nautilus" scontext=user_u:system_r:unconfined_t:s0 tcontext=user_u:system_r:unconfined_t:s0 tclass=process
sd 4:0:0:0 SCSI error: return code = 0x8000002
sdb: Current: sense key: Medium Error
end_request: I/O error, dev sdb, sector 0
(the last three lines were repeated two more times, and then ...)
sd 4:0:0:0: Attached scsi removable disk sdb
sd 4:0:0:0: Attached scsi generic sg1 type 0

These message were repeated, with the addition that the second time around I got "Buffer I/O error on device sdb, logical block 0".

I'm not sure how serious these errors are. The zip drive and disk work fine under Windows 2000.

So I followed David Chipman's advice about not following advice literally. I tried to mount the drive:

$ mount -t vfat /dev/sdb /media/zip

(By the way, I am logged in as root through su, and I created the directory /media/zip previously.)

The command returned this:

mount: wrong fs type, bad option, bad superblock on /dev/sdb,
           missing codepage or other error
           In some cases, useful info is found in syslog - try
           dmesg | tail  or so

$ dmesg | tail
...
FAT: invalid media value (0x6d)
VFS: Can't find a valid FAT filesystem on dev sdb.

OK. Then I tried Tim's suggestion:

$ /sbin/fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot       Start       End      Blocks    Id   System
/dev/sda1    *              1         13      104391   83   Linux
/dev/sda2                  14     9729   78043770   8e   Linux LVM

... and then the zip drive made a noise and the screen hung. I started typing this e-mail. Several minutes later, the zip drive made a noise again and the shell's prompt returned.

Do the errors indicate a bad disk? Do I need to change /etc/fstab? Any other ideas?

David Levner
--


The standard zip disk formatting was to put the data in the fourth partition - so you should be looking for /dev/sdb4.  This is  the same scheme that many usb thumbdrives use.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]