[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Where's /dev/sda4?



On Wed, 2007-01-24 at 12:44 -0800, David Levner wrote:
> $ /sbin/fdisk -l
> 
> Disk /dev/sda: 80.0 GB, 80026361856 bytes
> 255 heads, 63 sectors/track, 9729 cylinders
> Units = cylinders of 16065 * 512 = 8225280 bytes
> 
>    Device Boot       Start       End      Blocks    Id   System
> /dev/sda1    *              1       13     104391   83   Linux
> /dev/sda2                  14     9729   78043770   8e   Linux LVM

Shows why sda4 didn't work with your Zip drive, sda is your main hard
drive.  Your Zip drive will be at another device.  The other bit you
showed indicated sdb for your Zip drive, presuming it's one of those 250
odd MB versions.

Depending on how its formatted, it could the first partition (sdb1), or
that strange method the preformatted discs use of being the fourth
partition, with no other partitions on the drive (sdb4), perhaps even
something else.  Zip discs always were a peculiar thing.

Running "fdisk -l" (in general, to show all drives), or specifically
against the drive with "fdisk -l /dev/sdb", should show what the system
can find out about the drive and its discs, but this doesn't bode well:

> ... and then the zip drive made a noise and the screen hung. I started
> typing this e-mail. Several minutes later, the zip drive made a noise
> again and the shell's prompt returned.
> 
> Do the errors indicate a bad disk? Do I need to change /etc/fstab? Any
> other ideas?

Could be.  Do you have more than one disc to try out?  Can you retry it
on another OS that worked with it before?

It's been ages since I've tried a Zip drive on Linux, and that was with
FC3.  Mine's an internal IDE/ATAPI drive, in another box.  It usually
worked fine, though.  How's yours connected?

> I followed David Chipman's advice about not following advice
> literally. I tried to mount the drive:
>
> $ mount -t vfat /dev/sdb /media/zip

I'd try "mount -t auto /dev/sdb1 /media/zip" but you probably need to be
root.  I know you said you'd su'd to root, but the $ before the mount
command indicates that you're not root.  It'd be a # if you were.

-- 
(Currently testing FC5, but still running FC4, if that's important.)

Don't send private replies to my address, the mailbox is ignored.
I read messages from the public lists.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]