[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Wine broken (or is it FC6)



After updating to Wine 0.9.30 , winecfg was crashing my Nvidia X
server -- fixed by getting the latest from Nvidia (legacy so it is the
last 6 series update).   However, I am still having the same problem
initializing Wine.

I have tried:
- 2.6.18 kernel
- 2.6.19 and full update
- SELinux turned off -- problem persists.
- wine 0.9.29 from tarball and rpm, and 0.9.30 from tarball
- removing and reinstlaling msttf fonts
- restarting computer and restarting xfs

Each time, winecfg hangs the first time it is run and creates
.wine-xxxx where xxxx is
a temp dir.  It is not using CPU cycles so it appears to be hung.  If
I kill it, move the
.wine-xxx dir to .wine, then run winecfg, I get a window frame which
just displays the info behind the window (other windows and
background, no text, no icons, nothing else).

I have the same problem when trying to run any other wine applicaiton.

Note that when I had 0.9.2 (?) on my box, winecfg worked fine.  Only
after I did a yum install wine with the old wine still in
/usr/local/*, did the problem start.

Can someone point me to log files or command switches I can use to try
to diagnose this problem?  I read of some others having similar
problems but never found a resolution.  I basically have very litte to
go on myself.  I've spent two nights on this and am getting
nowhere.....

Thanks,
--
Wade Hampton


On 1/25/07, Jonathan Berry <berryja gmail com> wrote:
On 1/25/07, Wade Hampton <wadehamptoniv gmail com> wrote:
> Tonight I applied a bunch of FC6 updates then downloaded and built the
> latest wine.  It still is hanging when running wincfg at the start:
>
>   $ winecfg
>   wine: creating configuration directory '/home/wadeh/.wine'...
>   Failed to open the service control manager.
>
> If I kill winecfg, I get a dir like .wine-PcQqhc which contains the
> settings and virtual drive.  I moved it to .wine then restarted
> winecfg.  At this point, I get a clear window with no menus, just a
> translucent frame showing the background.
>
> As this box was FC5 updated to FC6 and is x86_64, I am thinking there
> must be something wrong (fonts, libs, etc.).  Any ideas?

I have wine working just fine on my FC6 x86_64 box.  I suggest you use
the wine RPMs from extras.  Here is what I have (yes, this is a 64-bit
install, wine is only available 32-bit):
$ rpm -qa | grep wine
wine-capi-0.9.29-1.fc6.i386
wine-twain-0.9.29-1.fc6.i386
wine-esd-0.9.29-1.fc6.i386
wine-0.9.29-1.fc6.i386
wine-tools-0.9.29-1.fc6.i386
wine-jack-0.9.29-1.fc6.i386
wine-core-0.9.29-1.fc6.i386
wine-ldap-0.9.29-1.fc6.i386
wine-nas-0.9.29-1.fc6.i386
wine-cms-0.9.29-1.fc6.i386

I am not sure what is going on with your system.  Is there anything in
any logs that might give more clues as to what is happening?  I have
had some font issues on a 32-bit CentOS machine where no text would
display on anything running under wine.  This sounds different,
though.  I don't know.  Are there any more details you can provide us?
 Are you using AIGLX?  Have you tried without it?  What about SELinux?
 Just trying to rule out possibilities...

Jonathan

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]