[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Serial camera + RS232 > USB adapter



On Saturday 27 January 2007 22:38, Colin J Thomson - G6AVK wrote:
> On Saturday 27 January 2007 10:20:44 pm Anne Wilson wrote:
>
> Its a Sanyo VPC-G200E, listed in digKam so hoped the adapter my work
> (somehow)
>
> > Have you tried the linux hardware compatibility
> > list?
>
> Ah no, I'll take a look there..
>
> Thanks
>
> Colin
> --
> Fedora Core 6 ("Zod")
> KDE-Redhat-3.5.6-3.fc6
> Registered Linux user number #342953

Out of interest, I just installed digikam and had a quick play myself. I have 
an Olympus C2100-UZ. Not the oldest digital camera around here I'm sure but 
it's getting on a bit.

What I found out is:-

1) It refuses to work with the USB connection. It's a pre mount as mass 
storage type device and talks a special protocol that digikam seems to not 
know properly, so far as I can tell.

2) This camera also has a serial socket. So I just got the box out of the 
attic and retrieved the serial cable. Plugged it into a serial-USB adaptor 
and.... nothing happened. Looked in /dev. The device appears as ttyUSB0. 
Digikam only allows you to select /dev/ttyS0 - /dev/ttyS3 I think it was. So 
shut down digikam and open the file ~/.kde/share/apps/digikam/cameras.xml 
with a text editor and hack it to look something like this:-

<!DOCTYPE XMLCameraList>
<cameralist client="digikam" version="1.1" >
 <item port="serial:/dev/ttyUSB0" title="Olympus C-2100UZ" model="Olympus 
C-2100UZ" path="/" lastaccess="2007-01-27T22:39:41" />
</cameralist>

Save and start digikam. Now it works! Slow but I just downloaded a photograph 
from my camera.

Hope this gets you going.

Dave Fletcher

-- 
Registered Linux user number 393408

I use and recommend the email service at 1 & 1
For domain registration, email and web hosting please visit:
http://oneandone.co.uk/xml/init?k_id=6389763


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]