[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: why is my wireless totally borked in f7?

On Wed, 25 Jul 2007, Knute Johnson wrote:

 let me re-iterate -- until f7, wireless config and usage was a
no-brainer.  it just worked.  now, with f7, it just *doesn't* work.
so i'm curious if anyone else noticed problems right after moving to

Mine worked with FC4 but not FC5 and FC6.  F7 works.  It is all a
crap shoot.  Go back to FC6 or wait for F8.

The problem is a little more complex than that...

There is an issue with the Broadcom chipsets (bcm4306 in particular). I will explain it as well as my information will allow.

Some versions of the bcm4306 chipset work with the version 3 firmware, but do not have enough memory to load the version 4 firmware. The old bcm43xx driver uses the version 3 firmware. The new driver (bcm43xx_mac80211?) only works with the version 4 firmware. So older chipsets do not work with the new driver. And here is the fun part... Both chipsets have the same pci id, so it is hard to tell which of the two chipsets you really have. (Since the kernel module uses the pci id to figure which one to load, it has to pick one. It does not look at chip revision information. You have to hack the blacklist and pci info files.)


I believe this is a problem that was found after the module was written. I am not certain if there is a fix possible for this without removing and replacing hardware. (Which is hard if you have a laptop with the older chipset, like I do...)

Hope that helps...

"ANSI C says access to the padding fields of a struct is undefined.
ANSI C also says that struct assignment is a memcpy. Therefore struct
assignment in ANSI C is a violation of ANSI C..."
                                  - Alan Cox

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]