nVidia from Freshrpms, selinux

Jan Brosius jan.brosius at skynet.be
Mon Jun 4 09:56:59 UTC 2007

Claude Jones wrote:
> Installed the nVidia driver from Freshrpms on F7, along with the dkms package. 
> When I rebooted, I got a bunch of nVidia denied messages. Someone had 
> mentioned in another thread going to the nVidia forum and getting some 
> suggestions about dealing with selinux; I found the following page and tried 
> some of the suggestions - some of the commands pointed to files that didn't 
> exist: http://www.nvnews.net/vbulletin/showthread.php?t=72490
> Those didn't help.
> I turned selinux off, uninstalled the nVidia driver, and reinstalled it. Now 
> it appears to be working well with glxgears giving me nearly 3000 FPS.
> Can anyone suggest how to get selinux and the nVidia driver to play nice? 
I tried the commands below and then it worked after rebooting. I 
remember that I first installed

yum install kernel-devel xorg-x11-server-sdk pkgconfig
# yum update
# reboot

    and then I executed the following commands:

    # chcon -t texrel_shlib_t /usr/lib64/xorg/modules/drivers/nvidia_drv.so
    # chcon -t texrel_shlib_t
    # chcon -t texrel_shlib_t /usr/lib64/libGLcore.so.1.0.9631
    # chcon -t texrel_shlib_t /usr/lib64/tls/libnvidia-tls.so.1

     (someone replied that livna has fixed the problem in the following

    Hope this helps

More information about the fedora-list mailing list