How to get rid of FC8 stuff?

Arch Willingham arch at
Mon Jun 4 20:05:52 UTC 2007

I nice guy over on the helped me with this and had me run these commands:

yum -y install yum-utils
mkdir rpms;cd rpms
yumdownloader $(rpm -q --qf '%{NAME} ' $(rpm -qa | grep fc8))
rpm -Uhv --oldpackage *.rpm

It worked for the most part. Once I fired off the next to last command, it gave about eight "No Match for argument " errors and then started downloading. This output looked like this:

yumdownloader $(rpm -q --qf '%{NAME} ' $(rpm -qa | grep fc8))
Loading "installonlyn" plugin
No Match for argument samba-swat
No Match for argument evolution-sharp
No Match for argument yumex
No Match for argument ksh
No Match for argument beagle-evolution
No Match for argument beagle
No Match for argument beagle-gui
No Match for argument lirc
gnome-keyring-0.8-1.fc7.i 100% |=========================| 179 kB 00:01 

After it finished, I tried running the next command and it popped back with:

rpm -Uhv --oldpackage *.rpm
error: Failed dependencies:
samba = 0:3.0.25a-2.fc8 is needed by (installed) samba-swat-3.0.25a-2.fc8.i386

Then I whacked out the eight error packages and reran the command 'rpm -Uhv --oldpackage *.rpm'. It seemed to work like a charm! Then I yumed back the eight packed I whacked above and all seems to be well.


-----Original Message-----
From: fedora-list-bounces at
[mailto:fedora-list-bounces at]On Behalf Of Michael Schwendt
Sent: Saturday, June 02, 2007 6:05 PM
To: For users of Fedora
Subject: Re: How to get rid of FC8 stuff?

On 02/06/07, Arch Willingham wrote:
> OK...I screwed up. I have been running FC7 test4. Yesterday, I upgraded to the FC7 final release. This morning, I ran a yum update and saw a ton of stuff flying by. After it finished, I rebooted and found that there were now a ton of FC8 files/updates on there. After doing some digging, I see that the yum config info was pointing (or whatever y'all call it) to the test releases. I fixed it so that it is now pointing to the right place.
> Is there any way to fix what this morning's update did? I.E. can I replace the FC8 files with FC7 files?

No recipe, just a few hints:

  rpm -qa --last | less
  rpm -Uvh --oldpackage ...

Probably with a bit of scripting. I don't know what the yum
allowdowngrade plugin does.

fedora-list mailing list
fedora-list at
To unsubscribe:

More information about the fedora-list mailing list