F7 install from DVD iso

Ed Gurski ed at gurski.com
Wed Jun 6 19:35:54 UTC 2007

On Wed, 2007-06-06 at 14:58 -0400, fedora-list-request at redhat.com wrote:

>    9. Re: F7 install from DVD iso - (Bob Goodwin - W2BOD)
> Date: Wed, 06 Jun 2007 14:32:12 -0400
> From: Bob Goodwin - W2BOD <bobgoodwin at wildblue.net>
> Subject: Re: F7 install from DVD iso -
> To: For users of Fedora <fedora-list at redhat.com>
> Message-ID: <4666FDAC.7050909 at wildblue.net>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> Kam Leo wrote:
> > On 6/5/07, Kam Leo <kam.leo at gmail.com> wrote:
> >
> > This write-up, http://fedoranews.org/dowen/nfsinstall/ , is fairly old
> > but should provide you with the basics.
> Yes, that's a reasonably clear instruction but Applications\System 
> Settings\Server Settings\NFS
> does not seem to exist in Gnome in FC6.  I am told that it's possible to 
> do this from the command line but there's no mention of what files need 
> to be dealt with.
> I found a similar application hidden deep in KDE which seemed to have 
> some effect on my installation attempt but in the end I still get the 
> error message that it can't find the directory?
> If Fedora set out to make installation of F7 more difficult they have 
> definitely succeeded!
> Bob Goodwin

Ok, I was able to do a NFS install and here is some simple things to do:

As Bob said, make sure NFS is running (/etc/init.d/nfs)

Make sure that you have something in /etc/exports --- where the file you
want is located.
Here is my sample /etc/export:

If you are running 64 bit, then it can also go in this directory or
wherever you want. Just make sure the the ISO image is the only file and
the directory name is in /etc/exports

Once you've created the /etc/exports file then issue
"sudo /sbin/service/nfs restart"

Then to ensure that you can export the directory, issue the command 
"sudo /usr/sbin/exportfs -a -v"

You should now see your directory as defined in /etc/exports.

Now I run a very secure network, I run IPCOP and also have SELINUX and
the Firewall turned on. Now since NFS is unencrypted, it is blocked by
IPTables by default. In order to make sure I could do a NFS install, I
turned off the firewall on the system that had the ISO.

You should now be able to mount it..
If the firewall is not off, you will see a "No path error".

Now boot with your rescue CD and select upgrade. It will then go through
a few screens and ask the method. Select NFS and fill in the blanks...


Ed Gurski <ed at gurski.com>

More information about the fedora-list mailing list