Much Challenge Getting F7 Installed

tom tfreeman at
Fri Jun 8 15:16:43 UTC 2007

Well, its been fun so far... NOT! I'd post a bug report, but I don't think 
I can offer enough details to make it worth the engineer's time to fool 
with. Perhaps bitching here can improve my report to make it worth while.

I would like to tryout F7 on one of my machines. I have downloaded and 
burned the DVD which passes the media check at the beginning of the 
install sequence. I suspect that the victum machine may be a little light 
on RAM with 256  MB installed, but I'll have to dig for further details on 
the hardware, because I've forgotten the details in the past 2 years.

FWIW, I did remember to backup to external HD both my personal data/files 
and the /etc directory tree. I've been known to forget that step.

The first attempt, I went for an update rather than a full install, using 
the full graphical installer. Things went very well until installing the 
eighth package, where it hit a wall and just sat there. I examined the 
four virtual consoles and didn't find any obvious error conditions, so 
what ever hit me, didn't lock up the console.

Second attempt was an update again, but using the nongui version of the 
installer. This attempt got roughly half way through before hitting the 
wall. Again, I found no obvious error announcements in any of the four 
virtual consoles.

Third attempt I gave up the idea of updating, and went for a fully clean 
install in the gui. I tried to let it run the network, and it hung up on 
getting an ip address via dhcp from the server. Reboot.

Fourth attempt, I went for a clean install in the gui, but forget about 
the network configuration attempt. No point in tempting fate again, but of 
course I already had.  I had tried to customize the package list. I got 
something like 900 of 1100(?) packages installed, and the installer died, 
with an error message for once. Of course, the message asked me to copy 
it down, and was the better part of 50 or 60 lines long. I'm not that 
confident with pencil and paper in the middle of the night, and didn't 
recognize any particular line as most critical. I think I noticed 
something about being out of memory however.

Last attempt was a clean install, nongui, with just a desktop selected. I 
did get a bootable system, vaguely sort of. Actually, the boot sequence 
hung hard looking for the ip address with dhcp. I could boot single user, 
and fiddled with dhclient and friends. No joy, and extremely poor notes, 
so I cann't really document what I tried. Eventually, I got into X as 
root, and ran the network configuration routine which worked, but please 
don't ask how I got there. I gave up for the morning at that point, and 
went to bed.

I'm almost half tempted to wipe the appropriate partitions clean again, 
try again, and if I get a goof up make a long day trip down to RH to let 
one of their engineers try and document the challenge. I'd have to get the 
invite first of course. I've been threatening to do that since RH4.0 or 
so, so I'm not too worried about it.

Ok. What do I need to dig up to make this into a possibly usable bug 

More information about the fedora-list mailing list