Wifi problems (FC 6)

Joe Barnett joe.barnett at mr72.com
Sat Jun 9 11:44:10 UTC 2007

Hash: SHA1

Anne Wilson wrote:
> I need to run this box on a wireless connection, and am having some problems.
> 1 - I have a very poor signal, considering that the box is only around 3m 
> (10ft) from the router.  I changed the antenna on the router to one that says 
> it increases range by up to 50%, maximum 40m, but the strength received 
> hasn't altered.  I still get only 40% strength.

Maybe time for a new router/access point?  I was having issues with
my original access point (similar: it started to lose power/signal,
if that is the correct way to phrase it) and finally just replaced
it.  Of course this happened just following expiration of the

> 2 - I thought that wpa_supplicant cached the passphrase, but it doesn't seem 
> to.  I still have to give the passphrase after bootup completes.

Maybe I am doing this wrong, but I keep the passphrase in

        ssid="ssid name"
	psk="hashed passphrase"

Keep wpa_supplicant.conf readable only by root: 0400 or 0600

I run my script to kick off wpa_supplicant at the start of rc.local.
 There may be a better way, but it works well enough.

> 3 - At bootup, ntpd tries to run before there is a connection.  I'd like to 
> get the connection up in time to use ntpd at boot.  What would I need to do?
> Thanks
> Anne

Try running "ntpd -gq" at the end of rc.local to sync the clock.
Then kick off nptd (with your normal settings) following that.

I have been using OpenNTPD (www.openntpd.org) for several years.
Starting OpenNTPD with the "-s" flag should obviate the need for
"ntpd -gq" or ntpdate earlier in the sequence, but I do both (if for
no other reason than to feel I am covering all bases).

Two notes: 1) I am not trying to start an ntpd war by mentioning
OpenNTPD, and 2) "ntpd -gq" is valid only for the stock ntpd
(/usr/sbin/ntpd), OpenNTPD accepts only two or three startup
options, and "-gq" are not among them.

So my rc.local looks something like this:

# wpa_supplicant

# sync clock
/usr/sbin/ntpd -gq

# start OpenNTPD
/usr/local/sbin/ntpd -s -f /usr/local/etc/ntpd.conf

One final note: the laptop to which I am referring stays in the
house and uses a local timeserver from which to sync; I have high
confidence that "ntpd -gq" will sync quickly, exit, and allow
rc.local to continue to be processed.  I have a MacBook which
travels and I use the same sequence in it (sans the wpa_supplicant
stuff, of course) and it seems to work well.  YMMV.

Good luck,

- --
E-mail: joe.barnett at mr72.com
Web: http://www.mr72.com/
AOL IM: JoeBarnett
Phone: 623.670.1326

Version: GnuPG v1.4.6 (GNU/Linux)


More information about the fedora-list mailing list