Weird USB keyboard/mouse problem

Kamal Shaker kys-fedora at
Mon Jun 11 06:30:14 UTC 2007

Just recently, in gnome, the keyboard and mouse stop responding to most
input, except, alt-tab, control-tab, the shift equivalents of those and
control-alt-f1 etc. No other keys will respond, the mouse moves but I
can't select any windows.

After pressing control-tab/shift-tab a few times (with the
desktop/window focus changing as appropriate), it all goes back to
normal for a while.

This only odd messages I see in the logs are:
Jun 10 22:21:10 xxx kernel: atkbd.c: Spurious NAK on isa0060/serio0.
Some program might be trying access hardware directly.
Jun 10 22:27:51 xxx kernel: usb 1-3.3: usbfs: USBDEVFS_CONTROL failed
cmd hald-addon-usb- rqt 192 rq 9 len 8 ret -110

It doesn't matter if the keyboard in plugged into a USB or PS/2 port,
it's still the same. I've tried several different USB ports aswell.

The only other odd thing is, in VMware keys will very quickly repeat,
making typing anything impossible.

Any ideas?


Kamal Shaker, email: kys at   WWW:
   Science has promised us truth. It has never promised us
   either peace or happiness. - Gustave Le Bon.

More information about the fedora-list mailing list