Mounting USB storage devices

Terry Polzin foxec208 at
Fri Jun 15 13:21:22 UTC 2007

On Friday 15 June 2007 08:53:14 Claude Jones wrote:
> On Wednesday June 13 2007 1:33:57 pm Terry Polzin wrote:
> > When I mount a USB memory device whether it be a key or a hd in an
> > enclosue as a mortal user (in KDE) I get a pop-up after the mount
> > dialogue stating that /media/X is a folder but a file is expected.  The
> > device mounts, I just don't get a display of the contents.  Mounting the
> > same device as root in KDE works without error.
> >
> > Am I dealing with a HAL issue or a KDE issue?
> After working perfectly on my FC6 box for months, mine started doing the
> same thing. I then noticed that hald was failing to start during one
> bootup. I also found that I couldn't start it manually 'service haldaemon
> restart' - I tried 'setenforce 0' (to turn off Selinux), and that permitted
> haldaemon to start. I went into selinux configuration and turned off all
> enforcing against haldaemon, and that permitted it to start at boot time.
> However, it's still not auto-mounting in KDE -- I get the dialog window
> after I plug the device in, I tell it to 'mount in new window' and it opens
> the new window, but the device contents aren't displayed - that's the way I
> left it yesterday. I posted about this in a different thread, but got no
> responses. I just tried my pendrive in this machine, which is a fairly new
> 12 days old F7 install, and mounting worked perfectly. So, I'd say
> something did change with either Selinux or Hal - but I can't put my finger
> on it

Claude -

Hald is running fine, selinux is disabled totally.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the fedora-list mailing list