Portsentry & apcupsd & Fedora 7

Gene Heskett gene.heskett at verizon.net
Sun Jun 17 09:01:47 UTC 2007

On Sunday 17 June 2007, Rick Bilonick wrote:
>> Rick, post the 50 errors.  Even if no one has tried to compile
>> portsentry, the errors might indicate the nature of the problem.
>> No input,...no (or very little) helpful output.
>> --
>> --R
>> ------------------------------------------------------------------------
>> /Linux, and Open Software, an alternative./
>> Registered Unix <http://counter.li.org> user #409453
>It wasn't quite 50 errors but here is the output:
>]# ls
>CHANGES     portsentry.c         portsentry_io.c     README.COMPAT
>CREDITS     portsentry.conf      portsentry_io.h     README.install
>ignore.csh  portsentry_config.h  portsentry_tcpip.h  README.methods
>LICENSE     portsentry.h         portsentry_util.c   README.stealth
>Makefile    portsentry.ignore    portsentry_util.h
>[root at bilonick portsentry_beta]# make linux
>cc -O -Wall -DLINUX -DSUPPORT_STEALTH -o ./portsentry ./portsentry.c \
>                ./portsentry_io.c ./portsentry_util.c
>./portsentry.c: In function ‘PortSentryModeTCP’:
>./portsentry.c:1187: warning: pointer targets in passing argument 3 of
>‘accept’ differ in signedness
>./portsentry.c: In function ‘PortSentryModeUDP’:
>./portsentry.c:1384: warning: pointer targets in passing argument 6 of
>‘recvfrom’ differ in signedness
>./portsentry.c: In function ‘Usage’:
>./portsentry.c:1584: error: missing terminating " character
>./portsentry.c:1585: error: ‘sourceforget’ undeclared (first use in this
>./portsentry.c:1585: error: (Each undeclared identifier is reported only
>./portsentry.c:1585: error: for each function it appears in.)
>./portsentry.c:1585: error: expected ‘)’ before ‘dot’
>./portsentry.c:1585: error: stray ‘\’ in program
>./portsentry.c:1585: error: missing terminating " character
>./portsentry.c:1595: error: expected ‘;’ before ‘}’ token
>make: *** [linux] Error 1

As an old portsentry fan I had to go take a look at it again, and I found that 
file's line 1585 to have been mangled by a line wrapper function in 
somebodies editor.  Pull the next line up to make a long line out of it, and 
for completeness, delete the final t in "sourceforget".  No idea where that 
came from.  Then see if it will build.

And now I'm wondering if the whole archive file hasn't been compromised, I 
just found another reference to sourceforget.net in the README.install.  
There is such a site, but it has no connection to portsentry.

For that reason, I added craigrowland at users dot sourceforge dot net to the           
To: list above.  Maybe he can refresh that file on sourceforge and restore 
our paranoia.  However, I note that the bugtracker has an entry, unresolved, 
dated in October of 2003, the year it was moved to sourceforge.

I liked portsentry.  Between that, iptables and tcpwrappers, nothing got past 
an old rh7.3 box I used for a firewall for 5 or 6 years.  The logs said many 
thousands tried though.  But even that was cut back by 99.9% when I got dsl, 
found roaring penguins PPPoE was crap and bought a linksys BEFSR41 router.  
It then stopped the huge majority of that crap.  Now I'm using dd-wrt on 
another old box to replace both of those boxes, and its just as bulletproof & 
uses 300 watts less power...

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
My interest is in the future because I am going to spend the rest of my
life there.

More information about the fedora-list mailing list