adding a service to xinetd (solved)

Don Russell fedora at
Fri Jun 22 03:59:27 UTC 2007

Don Russell wrote:
> Fedora 7
> I have a small telnet server listening on port 23, and want to run a 
> second one on port 8023 (rather arbitrary) which I'll use for testing 
> changes to the server app I wrote.
> The one on port 23 works properly but when I try to connect to the one 
> on port 8023, I get an error: connection refused.
> I tried this from the command line: telnet localhost 8023
> and I get the 'connection refused' error.
> I added port 8023 using the"firewall settings"... but it still fails, 
> I also restarted xinetd to pick up the additional server...
> SELinux is in permissive mode.
> I've obviously missed something.... but what?
> Thanks.

xinetd was not starting properly because:
1 -
I specified a service name of 'telnet' but a port of 8023. /etc/services 
says telnet is on port 23
I created a new 'service' in /etc/services on port 8023 and xinetd was OK

2 -
When I tried to add port 8023 using the admin/firewall tool... the 
change did not "stick"... that is, I added the port, clicked apply/ok... 
but when I went to look at the settings again, port 8023 was no longer 
in the list.

I d/l the 'firestarter' package and used it to define a 'rule' to allow 
port 8023 from my internal network.

That seemed to have overwritten all the firewall rules so it was the 
only service that was working properly until I added all the new rules 
with firestarter.

We're golden.. it's all working now.

Thanks to those who replied with ideas and suggestions.
I hope this summary might be helpful to future archive-searchers. :-)

More information about the fedora-list mailing list