Permission to run DRI

Kevin J. Cummings cummings at
Fri Jun 22 19:38:16 UTC 2007

Karl Larsen wrote:
> Frank Cox wrote:
>> I just noticed that when I run glxgears stuff on this computer (which
>> is an
>> Intel 82915G/GV/910GL Integrated Graphics Controller) I get this:
>> libGL error: open DRM failed (Operation not permitted)
>> libGL error: reverting to (slow) indirect rendering
>> When I run glxgears as root, it works as expected (without this error).
>> My /etc/X11/xorg.conf contains this:
>> Section "DRI"
>>         Group        0
>>         Mode         0666
>> EndSection
>> It is my current understanding that this should allow all users to
>> access DRI,
>> but apparently it doesn't.
>> What do I need to change to fix this?
>    Hi Frank, the /etc/X11/xorg.conf is a file that says nothing about
> DRI perhaps because I have FC6. But the file itself has this:
> [root at localhost X11]# ls -al xorg.conf
> -rw-r--r-- 1 root root 568 Jun 18 17:31 xorg.conf
> [root at localhost X11]#
> So whatever reads xorg.conf has to have root.

Bzzzt.  Wrong answer.  But, thanks for playing.  Anyone can read this
file (note the "r"'s is the user, group, and other positions).  Only
root can "write" to this file.  In fact, the only process which "reads"
this configuration file is X itself.  X then makes use of the
information it finds when processes query the X-server for their own use.

Having the DRI mode set to 0666 should allow any process to read or
write to the X server using DRI.  That said, something else must be
wrong with the OPs setup.  Perhaps some of the errors in the Xorg log
file can help shed some light on the answer....

> Karl

Frank, have you looked at your Xorg log file yet?

Kevin J. Cummings
kjchome at
cummings at
cummings at
Registered Linux User #1232 (

More information about the fedora-list mailing list