running programs from user acctount as root

Tim ignored_mailbox at
Mon Jun 25 10:55:31 UTC 2007

On Sun, 2007-06-24 at 20:59 -0700, Ashley Pritchard wrote:
> I am new to this list but have been using Fedora since the beginning &
> Before that I was using Red Hat. I have recently upgraded from FC6 to
> Fedora 7. Since then I have had to reinstall it a couple of times. The
> first time was due to seLinux being set as default as enforced & it
> would not allow me to download programs from the internet so I had the
> gumshoe to attempt to uninstall it.

It's the first time I've heard SELinux preventing downloads.  I think
you ought to give more details about how you tried (saving files with a
web browser, saving locally or over NFS, etc.).

> Then shortly after that I started having trouble useing programs that
> require root access from my user account.

Examples?  How were you getting root access first?  "sudo", "su -",
something else?

> I am able to login as root when that package updater says that there
> are updates available but the application will not run & neither will
> any other program that requires root access to run. However I am able
> to login to gnome as root from the GDM & run all the programs I want.
> I tried deleting the user account & creating another user account with
> a totally differnet user name & password & the same thing occurred.

Same as which?  Same as your account, or the same as logging in
graphically as root?

> Overly frustrated with attempting to get the DVD, MP3 etc support, I
> did not want another problem to resolve so I just re-installed the OS
> again to start over again. So here I am again. I dissabled seLinux &
> this time refused to download & install any updates to seLinux but yet
> again I am not able to run the package updater or any other program
> that requires root access from my user account.

This one was a fresh install?  (Not over the top of an existing
installation, but instead of the prior one.)

And how did you disable SELinux?  There's different techniques.

>  I am entering the password correctly & am able to login as root in
> the terminal but when I type the command 'pup' for the package updater
> I get the following: 
>      Xlib: connection to ":0.0" refused by server
> Xlib: No protocol specified

And what about using "yum"?  (A command line tool for updating.)
Perhaps, updates to a few things would get things working on your

> I would tell you what my system log says but I am useing my user
> account & can not access it with out loging out & back in as root.

Next time, while still root.  Copy the log file to your homespace, and
chown it to yourself.  Then you can use it when you're logged in as

While root, you can probably "su - yourusername" to run your mail client
as yourself.  Even if the other way around didn't work.

[tim at bigblack ~]$ rm -rfd /*^H^H^H^H^H^H^H^H^H^Huname -ipr
2.6.21-1.3228.fc7 i686 i386

Using FC 4, 5, 6 & 7, plus CentOS 5.  Today, it's FC7.

Don't send private replies to my address, the mailbox is ignored.
I read messages from the public lists.

More information about the fedora-list mailing list