f7 dead and recovery disk hangs.

Alan Cox alan at lxorguk.ukuu.org.uk
Thu Jun 28 10:39:44 UTC 2007

On Wed, 27 Jun 2007 23:02:38 -0400
"Robert Cahn" <robertscahn at gmail.com> wrote:

> I have a F7 system.  It uses the x86_64 distribution.  We had a lightning
> storm and I was away.  When I got back the system had hung and wouldn't
> reboot.  When I tried to put in the recovery CD and restore the system it
> loads in a number of SCSI drivers.  When it gets to, "Loading sata_sis
> driver" progress halts.  After a while garbage fills the middle third of the
> screen and the disk spins on and on.  I've tried to reinstall F7 but the
> same thing happens.  It appears the sata_sis driver is corrupted and the
> system cannot update without it.  Does anyone know a word around?

If reinstalling does the same (the installer uses its own copy of the
driver off CD) then the PC hardware probably got damaged by the storm, or
something else bad has happened with freak timing.

I would start from the beginning
	- Check all the system fans are running properly
	- Run memtest86 for a few hours 
	- If the SATA card is a plug in one reseat it in case it has
	- Check the SATA cables
	- Move the SATA drive to another system and check the drive is ok
		(If it does back up any data you want at this point)

if that finds nothing obvious then put it all back together, boot it and
if it still happens go into the BIOS settings and use one of the 'reset
to defaults' options. If that still fails seek expert advice as you may
need to replace the motherboard and some other parts if it got hit by a
power surge.


More information about the fedora-list mailing list