dd command to clear start of harddrive

Nigel Henry cave.dnb at tiscali.fr
Thu Nov 1 20:29:36 UTC 2007

On Friday 26 October 2007 02:59, Mikkel L. Ellertson wrote:
> Nigel Henry wrote:
> > Thanks to Andy for the dd syntax, but sadly, although it cleared the
> > start of the drive, I still couldn't get the Smoothwall to boot up post
> > install, just an "L" followed by a string of 40's after the BIOS memory
> > check. All a bit weird, as when I bought the machine about 4 years ago
> > when I first started with computers, it had Win 98 on it, and that worked
> > ok. I passed the machine onto my son, and he somehow got Win 2000 pro
> > installed on it. I know that was booting ok, because I tried it. It got
> > as far as wanting the password to get in, but as I don't know his
> > password I couldn't progress further, but at least it was booting, so it
> > doesn't seem to be a problem with booting from the harddrive.
> You should probably read the troubleshooting section of LILO. But I
> suspect the problem is in the BIOS of the machine you are trying to
> use. I suspect that you are trying to read part of the drive that
> the BIOS of that machine can not access. An updated BIOS may help.
> If not, using a /boot partition at the start of the drive will help.
> Remember, both LILO and Grub use the BIOS to access the hard drive.

Hi Mikkel. Sorry for the delay in my reply. I've been reading, reading, and 
more reading about LILO. I use LILO on my Debian installs, and havn't had 
problems with it. I believe you're right in it being a BIOS problem. I've 
been on the site that has docs, specs, etc for this AST Bravo MS 5133 
machine, and it was shipped with a 1.2GB HDD, and Win95, with possibilities 
of a 2GB one being used (1024 cyl limit in the BIOS setup). The drive my son 
had Win 2000 pro on is a 6GB one (13328 cyl). Quite how he got it set up, 
I've no idea, but I know it booted because I tried it. According to the same 
site there is a BIOS update available, but the machine shows that it already 
has it (circa 1996). According to the Enhanced IDE features, on this machine, 
I have.
Multi-sector transfer (which is set to auto)
32-Bit Disk I/O  (which is set as enabled)

The installation of Smoothwall Express2 creates four partitions, and uses all 
the drive, deleting whatever is on it.
hda1     /boot
hda2     swap
hda3     /var/log
hda4     /           (this one is flagged as bootable)

I had initially on the 6GB drive managed to install the Smoothwall, but 
couldn't reboot. I got an L, followed by a string of 40's. The L showed that 
the first stage of LILO was ok, and according to error codes, the 40 is a 
drive seek error. Booting up the Finnix live cd, and running fdisk -l, I got 
the partition setup as above, which corresponds with the partition setup on 
my current running Smoothwall.

> Depending on the version of LILO, there may be an option to use LBA
> addressing that sometimes also helps. I believe it is automatically
> used in the latest versions, but I could be wrong.

I don't know if I can make changes to LILO on the Smoothwall, as it's pretty 
nuch an automatic install, apart from OK'ing a few pages, and setting up the 
NIC, and entering passwords.
> One way to see if it is a BIOS problem is to try using the same
> drive in a more modern machine. If it boots without problems there,
> then it is a good indication that it is a BIOS problem, or that you
> are using 2 different settings for the hard drive. I have run into
> problems in that past where one machine used LBA, and another used
> the LARGE mode, or didn't support the newer modes, and you could not
> boot from the drive in the older machine anfer installing from the
> newer machine, even if they used the same processor.

Well I did try the drive in another machine, just to see if it was OK, and 
Smoothwall installed on it in about 5mins, and rebooted ok, but forgot to 
boot up the drive before re-installing the Smoothwall on it. I was sort of 
losing the plot by now though, so have no idea if the old Smoothwall install 
would have booted up on the newer (circa 2003) machine.

> Mikkel

Moving on a few days, and trying various incantations on this horrible P1 
machine. The Smoothwall installed in 5mins on my other machine on this 6GB 
disk, but will not run on the P1 machine, because the harddrive limit is 2GB.

I couldn't even get the P1 machine to initialise the harddrive, and ended up 
installing Win95 from a 13 floppy set. That wouldn't run to completion, as 
disk 13 failed on installing, but at least it had installed enough so that  I 
could run smart boot manager in the floppy drive, and boot Finnix from the 
cdrom drive, but no joy on getting the Smootwall installed on this machine.

Perhaps we should just close this thread as unresolved. I've spent many hours 
getting nowhere, and extremely frustrated in the process.

Apologies for the late reply, but I've been trying allsorts of incantations to 
get this damn machine to play ball with me.


More information about the fedora-list mailing list