Network install FC7

Craig White craig at
Thu Nov 8 22:25:59 UTC 2007

On Thu, 2007-11-08 at 15:01 -0500, Bill Davidsen wrote:
> Craig White wrote:
> > On Fri, 2007-11-02 at 15:55 +1030, Tim wrote:
> >> Tim:
> >>>> Which is it, FC 7 or 8?  The subject description is different from the
> >>>> message, and which one you're actually doing might be able to pinpoint
> >>>> the problem.
> >> Craig White :
> >>> solution the same either way.
> >> I'd have thought so, but I was asking in case there was some bug in the
> >> newest install routine.
> >>
> >>> copy iso to system that has httpd running, loop mount in /var/www/html
> >>> path somewhere...good to go.
> >>>
> >>> mkdir /var/www/html/FC8
> >>> mount -t iso /tmp/F-8-x86_64-DVD.iso /var/www/html/FC8
> >>>
> >>> linux method=http://MY_WEB_SERVER/FC8/disc1
> >> It occurred to me that you could have some SELinux issues from that sort
> >> of thing, if the contexts aren't in place to allow HTTP serving of those
> >> files.
> >>
> >> I did a network install of FC7 ages ago, but I can't recall what
> >> protocol I used.  Whichever technique it was, I would have copied the
> >> files to a directory, I didn't use a loop mount, or serve out the ISO.
> > ----
> > if you serve out as NFS, you don't need to loop mount. You only serve
> > the iso's themselves via NFS
> > 
> I think your terms "iso's" is the key, I used to export the tree with 
> the contents of the CD releases of everything up to FC5, possible FC6, 
> those distributions which came on CD. But now that the releases are 
> DVD-only, the installer can't seem to cope with the exported single ISO 
> image. Feel free to prove me wrong, if you can get a box to start 
> install past the point where it tries to get "stage2.img" you will be 
> past where I got using http or nfs export.
> Note that I was able to download the file with another machine using 
> either protocol, and verified the success with an MD5sum to be sure it 
> worked. The problem is with the install code, and I note that the 
> access.log of the http server shows that it is looking for things in a 
> "disk1/" directory, indicating the the install was moved from CD to DVD, 
> but the install script doesn't seem to have been.
> Again, feel free to point out some mistake I'm making, I've done a 
> *bunch* of machine with older distributions, and had no problem. And I 
> tried both the boot.iso from the DVD and the Live-CD install, with 
> stoppage at exactly the same point.
I wish that I could test out F7/F8 but I can see that it won't be
possible for me to do that.

I did install K12LTSP using that methodology but that was FC-6 and cd
based iso's

I am really geared up to install via http here as I run mrepo, and have
repository installation setups for fc6-i386, fc7-i386, fc7-x86_64,
fc7-ppc and am now downloading the DVD iso's for F8

In as much as I install - latest Dell Optiplex 320 with F7-x86_64
boot.iso via http...

linux install \
 method=http://my_mrepo_server/mrepo/fc7-x86_64/disc1 \

I would expect that the NFS install should work as well but I simply
can't test it out until well into next week as my primary concern is
getting the various f8 local repository mirrors all functional and
installs/updates rockin.


More information about the fedora-list mailing list