F8 - wireless problem - SOLVED

Jacques B. jjrboucher at gmail.com
Sat Nov 10 05:20:13 UTC 2007

On Nov 9, 2007 11:23 PM, Jacques B. <jjrboucher at gmail.com> wrote:
> Got wireless to work with WPA-PSK.  The solution was at
> http://fedoraforum.org/forum/showpost.php?p=857006&postcount=52
> As root I edited /etc/wpa_supplicant/wpa_supplicant.conf so that it
> contained the following:
> ctrl_interface=/var/run/wpa_supplicant
> ctrl_interface_group=wheel
>   network={
>    ssid="your ssid"
>    psk="your passphrase"
>    key_mgmt=WPA-PSK
>    proto=WPA
>   }
> The first two lines were already there.  I added the remaining lines
> as per the the instructions on the site above.
> I then ran
> # ifconfig wlan0 up
> # wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf -dd
> (the process didn't exit so it seemed, but after doing the next
> command successfully I was able to close this window anyhow).
> Then in another terminal window as root I ran
> # dhclient wlan0
> I could then close both the windows and the wireless worked.  I went
> into system-config-network-gui (either via command line or via System,
> Administrator, Network) and ensured that my wireless card was checked
> off so that it will start up on reboot (haven't rebooted yet but I am
> fairly confident it will work - if not I will repost to that effect -
> otherwise it worked).
> Jacques B.

I guess I was too confident.  It didn't work.  I still get the same
error at boot, which is:

Error for wireless request "Set Mode" (8B06) :
  SET failed on device wlan0 ; Invalid argument.

Also noted a mistake in what I first posted.  Instead of
/etc/wpa_supplicant.conf it should have read

I Googled the other error and found out that it was because I had to
ensure I selected Managed mode (I had auto).

So I corrected that which corrected the above error.  But now it ends
up with 4 packets sent and 100% loss.

Next I figured I'd put the commands in /etc/rd.d/rc.local.  Not my
preferred solution, but an interim one until I can get it to work
properly from the network configuration menu.  In order to not slow
down the boot process I unchecked the wireless card in
system-config-network-gui so that it doesn't try and activate it on
bootup.  When /etc/rc.d/rc.local runs the commands in it, it activates
the card and that does the trick.  But again I'd prefer to make this
work through system-config-network-gui rather than rc.local.

Any suggestions?

Jacques B.

More information about the fedora-list mailing list