F7 to F8: no joy =/

André Costa blueser at gmail.com
Wed Nov 14 01:31:38 UTC 2007


for the 1st time since RH6.0, I am unable to upgrade a RedHat OS. That sucks.

I have F7 (x86_64)  installed from scratch and up-to-date on an Intel
Core 2 Duo, 2GB RAM, SATA HD running in IDE mode (this machine
dual-boots with Windows XP, and it doesn't work with SATA). If I try
to upgrade, the whole thing runs ok (sort of) until the "checking
dependencies in packages selected for installation" step, where it
sits forever stuck on 99% completed -- and it seems to take too much
time to reach this stage IMHO. I tried both graphical and text
installations, no luck. I let it work that last 1% for _one_ hour, no
luck either.

I don't know any logs I could check -- tty[34] don't show anything too
suspicious AFAICS. I tried monitoring anaconda's process with strace
-c, and I got something like this after 1min:

pread: 337K calls, 50% of the time
gettimeofday: 147K calls, 18%
rt_sigprocmask: 115K calls, 8%
fcntl: 52K calls, 7.8%
stat: 21.3K calls, 5.3% -- and 15K errors
access: 18K calls, 3.5%, 12.4K errors

I hope these numbers mean something to someone. And I hope someone can
help me get out of this dead-end. Otherwise, I am stuck with F7, and
that doesn't make any sense to me.

Please let me know if there's any additional info I can provide.

Damn, this is really frustrating =/



More information about the fedora-list mailing list