dosemu 64-bit compile? - SOLVED

Zoltan Boszormenyi zboszor at
Wed Nov 14 09:10:07 UTC 2007

Frank Cox írta:
> On Wed, 14 Nov 2007 09:50:12 +0100
> Zoltan Boszormenyi <zboszor at> wrote:
>> I don't know why don't you get this error,
>> maybe we are using different dosemu 1.4.0
>> or different glibc-devel?...
> Well... it compiled and nothing blew up yet in my (so far, limited) testing now
> that I have it installed.
> Did you compile for i386 or x86_64?

For x86-64. The original src.rpm from doesn't build for me,
with this below:

Checking for unpackaged file(s): /usr/lib/rpm/check-files 
error: Installed (but unpackaged) file(s) found:

RPM build errors:
    user enbeo does not exist - using root
    user enbeo does not exist - using root
    File not found: /home/zozo/rpmbuild/BUILD/dosemu-root/usr/lib64/dosemu
    File not found by glob: 
    Installed (but unpackaged) file(s) found:

I.e the same that happened for you, and similar to what happened to me
on FC6/x86-64 before, so I modified the dosemu.spec file at the time:

--- dosemu.spec~        2007-11-14 10:02:47.000000000 +0100
+++ dosemu.spec 2007-11-14 10:02:47.000000000 +0100
@@ -21,7 +21,7 @@
 %setup -q
-./configure --prefix=%{_prefix} --mandir=%{_mandir} 
+%configure --sysconfdir=/etc/dosemu 
 mkdir -p $RPM_BUILD_ROOT%{_bindir}

I.e. so it uses the system specified directories for most things,
only the config directory is /etc/dosemu. After this change in
the spec file _only_, I now got the error I quoted, i.e.
 open(... , ... | O_CREAT) needs the 3rd (mode) parameter.
I fixed it the the second patch, and the v86dev-dosemu patch
makes dosemu on x86-64 very fast. The patch for vm86dev is
needed to compile it on F8 kernel, and supposedly mainstream
2.6.23[.1] as well.

Best regards,
Zoltán Böszörményi

More information about the fedora-list mailing list