F7 to F8: no joy =/

André Costa blueser at gmail.com
Wed Nov 14 11:14:59 UTC 2007

Hi Claude,

On Nov 14, 2007 12:14 AM, Claude Jones <cjones at levitjames.com> wrote:
> On Tue November 13 2007, André Costa wrote:
> > Please let me know if there's any additional info I can provide.
> >
> > Damn, this is really frustrating =/
> Lots of people reporting this issue including me. I did a yum upgrade on two
> machines that failed on upgrade from the DVD in the way you describe. Worked
> beautifully. It took a long time - I had to remove a couple of packages on
> one machine that failed dependency checks, but other than that, it worked.
> The usual little stuff is broken after the upgrade, but nothing show-stopping
> so far. Avahi ends up with two instances after the update, but you can google
> the fix for that - it's simple. Long time means overnight - there were around
> 1400 packages on each machine that got updated. Both were complete when I
> looked the next morning.

Thks for sharing your experience. Well, something is definitely broken
on F8 upgrade process, a Core 2 Duo should never need 1+ hour of
processing at 1.0 load to figure out the dependencies -- even if it's
just to realize it can't go further for some reason (eg. third-party
packages -- which I do have, from Freshrpms). I remember experiencing
similar delays with F6 --> F7 upgrade, but it wasn't comparable to
this. It looks like anaconda still needs some serious work.

Well, a network upgrade with yum should work, but what will happen if
I lose connection for some reason? Will it be possible to recover from
a half-completed upgrade? Is it possible to use yum to upgrade from
the installation DVD?

I'll try to file a bug report for this (if there isn't one about it
yet) hoping that F9 will come with a anaconda that works =/



More information about the fedora-list mailing list