Buffer I/O error on device sr0

Joachim Kunze joachim at resistance.de
Wed Nov 14 13:04:33 UTC 2007

I couldn't access DVDs (CDs worked fine) either, so I've tested the
kernel parameter "libata.dma=1" which also didn't work for me. After
putting  "options libata dma=1" in /etc/modprobe.conf anything works
fine again.



Am Montag, den 12.11.2007, 21:33 +0000 schrieb Mario Rossi: 
> >Justin Conover írta:
> >
> >    Seeing the following in dmesg referring to my dvd drive when I try and play something:
> >
> >    end_request: I/O error, dev sr0, sector 205572
> >    Buffer I/O error on device sr0, logical block 51393
> >    Buffer I/O error on device sr0, logical block 51394
> >    Buffer I/O error on device sr0, logical block 51395
> >
> >Do you also get scary messages about hardware errors, too,
> >like CRC errors during DMA transfer? If not, then your disk
> >may be broken or just dusty. Look for small spot(s) on the
> >data side, you may wash it off with warm soapy water :-)
> >However if you get CRC errors in the log too, I have to tell that
> >I got similar errors when booting the Fedora 8 install disk.
> >I had to work it around with using the "libata.dma=1" option
> >on boot. This only enables DMA for harddisks but not for
> I have the same error.
> I've tried libata.dma=1 at boot (after pressing "Tab") but I get that the option is invalid and it
> is ignored.
> I've added it at the end, after a few other options already there.
> What is the exact spelling?
> Cheers
Joachim Kunze
Alte Marktstrasse 16   eMail: joachim at resistance.de
D-71665 Horrheim       Tel:+497042-830006

More information about the fedora-list mailing list