qla2310 hba at boot time

Bob Kryger bobk at panix.com
Fri Nov 16 18:10:40 UTC 2007

OK - so i answered on of my questions. I pulled apart the current 
initrd, edited the init nash script removing the setquite command, 
verified that the firmware file was in the correct place, and then 
rebuilt my new initrd and rebooted.  Same situation, but now i can see 
that the only place that the module is loaded is in the initrd.

so, now to find out why the module cannot find the firmware.....


Bob Kryger wrote:
> I'd like to see them, thanks..
> That was my initial problem. I loaded up the firmware, but did not 
> rebuild the initrd. Then I rebuilt my initrd and then pulled the new 
> one apart to verify that the firmware was in there, and it is. But I 
> still get the same behavior.
> What is confusing me is when is the load being done?  I see the nash 
> script in the initrd has the insmod command in it and the firmware is 
> in the initrd, but the firmware is not loaded. I don't actually need 
> the qla for the boot as I am booting off an ATA disk.  I see what 
> appears to be a load of module in the dmesg with the error about not 
> finding the firmware, is this the message from the initrd sequence or 
> some other part of the boot up?
> So after working on this all day yesterday....
> 1. Is the output from the initrd loading and therefor the nash init 
> script in the dmesg?
> 2. is the initrd the only place that would load this module, or is 
> there some script after the initrd hands off to init that also loads 
> such modules? Where might that be? I cannot find such a script.
> 3. what is the best way to go about traking this down - hack my 
> initrd, or mkinitrd?
> 4. did i miss a step on regenerating my initrd?
> 5. I can certainly add a rc.local script or the like, but I'd rather 
> this worked as intended, and I've rather been enjoying digging into 
> parts of linux that I don't normally get to do. This is quite a change 
> from adding users, and fixing permissions and such...
> Thanks for your help
> Bob
> Mark Haney wrote:
>> Andrew Parker wrote:
>>> On Nov 15, 2007 2:33 PM, Bob Kryger <bobk at panix.com> wrote:
>>>> So, I have an F7 system w/ a QLA2310 HBA. Everything works OK, when 
>>>> done
>>>> by hand.
>>>> But when I reboot, the kernel module is not getting loaded correctly,
>>>> the firmware not loaded, then the md not assembled and not mounted.
>>>> So I unload the module, reload the module (which loads the firmware),
>>>> assemble the md0, and mount by hand and it works.
>>>> Questions:
>>>>   Why is the module load at boot time not loading the firmware?
>>>>   Where is that module load done in the startup sequence?
>>>>   How do I approach resolution correctly, avoiding hacking the 
>>>> startup?
>>> did you rebuild your initrd?  i seem to remember getting some
>>> wierdness with our 2312 cards (on RHEL, not Fedora) like that
>> Yeah I had the exact same problem last week and rebuilding initrd 
>> worked perfectly.  I have the instructions that someone posted (and 
>> whoever it was thank you!) I'll be glad to send them to you.

More information about the fedora-list mailing list