Serial Port Bug?

Karl Larsen k5di at
Tue Nov 27 22:05:24 UTC 2007

Albert Graham wrote:
> Karl Larsen wrote:
>> Lamar Owen wrote:
>>> On Tuesday 27 November 2007, Karl Larsen wrote:
>>>>     I have a software I like to use called gmfsk which uses the serial
>>>> port to turn on and off the transmitter in my radio. It worked fine on
>>>> my old computer. Now when I try to run gmfsk it puts up an error panel
>>>> that says "Not a serial or parallel port". This made me think the new
>>>> computer which has a serial port that is not working.
>>> Is the serial port enabled in the BIOS?  What does the command
>>> dmesg | grep ttyS
>>> give you? (upper case S).
>>    Hi Lamar, I get nothing from dmesg | grep ttyS   and I even tried 
>> /dev/ttyS :-)
> Try: dmesg|grep -i serial
> Also, I think the driver supports 4 ports rather than saying you have 
> 4 ports, as the chances are you only have 2 (one internal + one 
> external).
> Al.
    Well that gets nothing. And I have only one serial plug on the 
computer. Not sure why grep missed it...

    Yes this worked:

[root at k5di ~]# dmesg | grep Serial
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[root at k5di ~]#

It took a capital S in Serial :-)


	Karl F. Larsen, AKA K5DI
	Linux User

More information about the fedora-list mailing list