Serial Port Bug?

fred smith fredex at
Wed Nov 28 00:55:22 UTC 2007

On Tue, Nov 27, 2007 at 09:29:39PM +0000, Albert Graham wrote:
> Karl Larsen wrote:
> >Lamar Owen wrote:
> >>On Tuesday 27 November 2007, Karl Larsen wrote:
> >> 
> >>>    I have a software I like to use called gmfsk which uses the serial
> >>>port to turn on and off the transmitter in my radio. It worked fine on
> >>>my old computer. Now when I try to run gmfsk it puts up an error panel
> >>>that says "Not a serial or parallel port". This made me think the new
> >>>computer which has a serial port that is not working.
> >>>    
> >>
> >>Is the serial port enabled in the BIOS?  What does the command
> >>dmesg | grep ttyS
> >>give you? (upper case S).
> >>  
> >   Hi Lamar, I get nothing from dmesg | grep ttyS   and I even tried 
> >/dev/ttyS :-)
> >
> Try: dmesg|grep -i serial
> Also, I think the driver supports 4 ports rather than saying you have 4 
> ports, as the chances are you only have 2 (one internal + one external).

Karl, have you tried messing about with setserial (man setserial) to see
if it will report anything useful (or allow you to set up a port)?


---- Fred Smith -- fredex at -----------------------------
               But God demonstrates his own love for us in this: 
                         While we were still sinners, 
                              Christ died for us.
------------------------------- Romans 5:8 (niv) ------------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the fedora-list mailing list