[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Instruct yum to keep old kernels



Marcel Janssen wrote:
Missing Dependency: /boot/vmlinuz-2.6.22.1-33.fc7 is needed by package alsa-kmdl-2.6.22.1-33.fc7 Missing Dependency: /boot/vmlinuz-2.6.22.1-33.fc7 is needed by package ivtv-kmdl-2.6.22.1-33.fc7 Missing Dependency: /boot/vmlinuz-2.6.22.1-33.fc7 is needed by package nvidia-graphics100.14.11-kmdl-2.6.22.1-33.fc7

$ uname -r
2.6.22.1-33.fc7

I somehow don't understand the missing dependency unless yum is still trying to remove my running kernel.

I'm not sure about this particular problem but I has something similar happen when I was trying to update to the 2.6.22.4-65 kernel. It kept trying to remove kmod-ndiswrapper & ndiswrapper which I need for my wireless to work. I got around the problem by running
    yum update kernel kmod-ndiswrapper

In your case, the below (or something similar) should work.
    yum update kernel nvidia-graphics100 ivtv-kmdl alsa-kmdl

--
Regards,
विवेक ज. पाटणकर (Vivek J. Patankar)

Registered Linux User #374218
Fedora release 7 (Moonshine)
Linux 2.6.22.4-65.fc7 x86_64


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]