[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can't update rpm



El Domingo, 2 de Septiembre de 2007 15:53, Jesus Jr M Salvo escribió:
> On 02/09/07, Michael Schwendt <mschwendt gmail com> wrote:
> > On 02/09/07, Jesus Jr M Salvo <jesus m salvo gmail com> wrote:
> > > F7 x86_64. I can't update rpm with the latest updates. They all seem
> > > to depend on rpm = 4.4.2-46.fc7.
> > >
> > >
> > > # yum update rpm
> > > Loading "changelog" plugin
> > > Loading "fastestmirror" plugin
> > > Setting up Update Process
> > > Loading mirror speeds from cached hostfile
> > > Resolving Dependencies
> > > --> Running transaction check
> > > ---> Package rpm.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > --> Processing Dependency: rpm = 4.4.2-46.fc7 for package: rpm-build
> > > --> Processing Dependency: popt >= 1.10.2.1 for package: rpm
> > > --> Processing Dependency: rpm = 4.4.2-46.fc7 for package: rpm-devel
> > > --> Processing Dependency: rpm = 4.4.2-46.fc7 for package: rpm-python
> > > --> Processing Dependency: rpm = 4.4.2-46.fc7 for package: rpm-libs
> > > --> Restarting Dependency Resolution with new changes.
> > > --> Running transaction check
> > > ---> Package rpm-libs.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package rpm-devel.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package rpm-build.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package rpm-python.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package rpm.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package popt.x86_64 0:1.10.2.1-1.fc7 set to be updated
> > > --> Processing Dependency: rpm = 4.4.2-46.fc7 for package: rpm-devel
> > > --> Processing Dependency: rpm = 4.4.2-46.fc7 for package: rpm-libs
> > > --> Restarting Dependency Resolution with new changes.
> > > --> Running transaction check
> > >
> > > Dependencies Resolved
> > >
> > > =======================================================================
> > >====== Package                 Arch       Version          Repository   
> > >     Size
> > > =======================================================================
> > >====== Updating:
> > >  rpm                     x86_64     4.4.2.1-1.fc7    updates          
> > > 1.1 M Updating for dependencies:
> > >  popt                    x86_64     1.10.2.1-1.fc7   updates           
> > > 72 k rpm-build               x86_64     4.4.2.1-1.fc7    updates       
> > >    623 k rpm-devel               x86_64     4.4.2.1-1.fc7    updates   
> > >        5.5 M rpm-libs                x86_64     4.4.2.1-1.fc7   
> > > updates           920 k rpm-python              x86_64    
> > > 4.4.2.1-1.fc7    updates            58 k
> > >
> > > Transaction Summary
> > > =======================================================================
> > >====== Install      0 Package(s)
> > > Update       6 Package(s)
> > > Remove       0 Package(s)
> > >
> > > Total download size: 8.2 M
> > > Is this ok [y/N]: y
> > > Downloading Packages:
> > > Running rpm_check_debug
> > > --> Populating transaction set with selected packages. Please wait.
> > > ---> Package rpm-libs.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package rpm-devel.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package rpm-build.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package rpm-python.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package rpm.x86_64 0:4.4.2.1-1.fc7 set to be updated
> > > ---> Package popt.x86_64 0:1.10.2.1-1.fc7 set to be updated
> > > ERROR with rpm_check_debug vs depsolve:
> > > Package rpm-libs needs rpm = 4.4.2-46.fc7, this is not available.
> > > Package rpm-devel needs rpm = 4.4.2-46.fc7, this is not available.
> > > Complete!
> >
> > What has happened most likely is that you still have i386 rpm packages
> > installed, but only x86_64 repositories configured. Run
> >
> >   rpm -qa --qf %{n}-%{v}-%{r}.%{arch}\\n rpm\*
> >
> > to find out. Get rid of the i386 packages, exclude= them in yum.conf
> > if necessary.
>
> Thanks ... that was it ... an i386 rpm of the same name. However, I
> could not just "exclude=*.i386" ... there's too many of them such that
> if I update rpm, it tries to update popt but it too has an i386 rpm
> that is depended on by other i386 rpms and so forth .... Is there a
> clean and safe way to uninstall all the i386 rpms ?
>
> John

Probably you're going to have dependence problems anyways if you try to 
unistall them all, you can force it using --nodeps, but if I were you I'd not 
do that.

You might need to take a look at the dependences, how critical and how many 
are they...
Good luck, mate!
Manuel

-- 
Manuel Arostegui Ramirez.

Electronic Mail is not secure, may not be read every day, and should not
be used for urgent or sensitive issues.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]