[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yumex wedges upgrading kernel in /sbin/new-kernel-pkg & friends



Andy Green wrote:
> 
> Somebody in the thread at some point said:
> > Gang,
> > 
> > I'm looking for suggestions on this one....
> 
> >>  5085 pts/10   D+     0:00  |                                                   \_ /sbin/nash --forcequiet
> 
> Why not run yum via strace -f and try to figure out what nash is up to.
> 
> One of the things mkinitrd likes to do, maybe via nash, who knows?, is
> reach out and twiddle devices like floppies.  If there is something
> about your floppy situation that could invite a hang...
> 
> -Andy
> 

Well, I tried "strace -f yum update" inside of script(1)... and it worked, sorta.
The /boot/grub/grub.conf file wasn't updated; had to do that by hand.

It also produced a 1356119 line typescript file that didn't mention nash anywhere.

Thus, at a minimum, we can conclude:
	1- yum != yumex
	2- mkinitrd and/or nash is brittle, especially with yumex
	3- updating grub.conf is brittle, especially with yum.
and finally,
	4- upgrade kernels with yum, not yumex, and
	5- check your answers twice before rebooting.

Thanks, Andy.

-S


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]