[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

how to fix a nackered system by fixing every installed rpm ?



Hi, I am recovering a system that has a corrupted system drive after a disk death in a raid 5 array. Unfortunately the disk rebuild on a new disk (larger size) didn't go well. Some files are fine, others have dir entries, but are full of crap.

Booting linux rescue, I have fsck.ext3 the lvm root vol and it fixed the structure errors for more than one hour. It still didn't boot.

It looks like all the dir entries are there, and the contents of some files {eg text files in /etc/ and /root/} are OK, other file just have junk chars {blocks in midnite commander}.

When I tried to chroot /mnt/sysimage, It complained {I forget what} and didn't chroot.

I have another similar machine with same OS and updates, so {backed up the corrupt rpmdb and} copied the rpmdb from the other machine. I copied all the rpms from the install dvd into some available space {separate logical volume}.

I tried to --rebuild the rpmdb, but no success {probs with DB3}. rpm -V shows thousands of md5 bad files. I am able to eg:
# rpm -Uvh --root=/mnt/sysimage rpm --force
So I have over-installed various bits that are missing, and managed to get db4, rpm, and yum to be able to run.

I yum install gtk2 and it says nothing to do, but rpm -V gtk2 shows a heap of problems.

Is there a way to get yum to reinstall what rpm says is installed, but in fact is not actually there ?
{doing it with rpm alone seems like a long way around ?}.

Any other ideas ??

Ta, DaveT.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]