[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Sound in Fedora7 on a VPC2007 virtual machine?



On Sat, 2007-09-08 at 14:27 +0200, Bo Berglund wrote:
> As can be seen in my thread concerning successful installation of F7
> in VPC2007 I am still missing sound support.
> It is very strange because if I enter the menu command 
> System/Administration/Soundcard detection
> I get to a window where I can test my emulated soundcard (Soundblaster
> 16) and it produces really nice sounds.
> 
> But when I go to the menu command
> System/Preferences/Hardware/Sound and enter the Sounds tab where there
> are a number of system sounds to select and test, there is no sound
> when I click the play buttons.
> 
> So what is the problem here?
> (Someone suggested to check the Alsa Mixer, but that did not lead
> anywhere).
> 
> 
> Bo Berglund
> 
Alsa mixer, the volume control (system>volume) and your windows controls
will all interact because the sound board has only one set of registers.
I have used sound in more than one application on Linux successfully and
also in Windows.  But I am dual boot, not virtual machine.  Someone else
will have to advise you about that interaction.  In the meantime, the
volume control must be well up, and alsa mixer main and pcm must be up
at a minimum to get sound from any application.  You can also go to the
system>preferences>sounds and see if you can hear the system sounds.  Or
you can turn on your microphone and see if you can get it to work after
checking that it is not muted.

mine works all the time in linux, even with no application open.

After all that is said, I don't know where to look next.  However, I did
use the command line form of alsa mixer once when I had a similar
problem, and once sound worked there, it worked everywhere, so I guess
there is some file where settings are stored, and that may be an issue
for you.  That file will be most likely in the
usr/usrname/.gnome2/gnome_volume_control, so you will want to make sure
that you have write permission to that file.

I have not found the alsa control file, but I am pretty sure that there
is one because of how it works and how the cards work (I am basically a
hardware guy).

Regards,
Les H


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]