[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 and libcom_err.so.3



Tod wrote:
> I recently installed subversion.  I wanted to start creating and
> using a repository so I issued the svn command.  It failed due to
> missing libcom_err.so.3.  I checked and it seems to belong to a
> kerberos RPM.

Did you install from the Fedora rpm packages or from somewhere else?
The latest subversion for FC6 would appear to be 1.4.3-2.fc6.  That
rpm requires libcom_err.so.2:

$ rpm -qp --requires subversion-1.4.3-2.fc6.i386.rpm | grep libcom
libcom_err.so.2

Which is provided by e2fsprogs-libs:

$ rpm -q --whatprovides libcom_err.so.2
e2fsprogs-libs-1.39-7.fc6

> Has anyone else run into this?

I haven't logged into my FC6 system in a few weeks or so, but svn
worked the last time I tried it, using what I believe to be the
current version.  It is possible some update since then has broken
things and I haven't noticed because I haven't logged in and updated
that system.

> But I am curious to see if it isn't something I'm missing.  Its odd
> that a RPM dependency would contain an older library.

I think something is amiss on your system, though I'm not sure what
that is.  Do any of the following commands report anything
interesting?

$ rpm -q --requires subversion | grep libcom

$ rpm -V subversion

$ locate libcom_err.so.3

$ rpm -q --whatprovides libcom_err.so.3

Also, what's the exact error you get when you run the svn command (and
the command you're running)?

-- 
Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
God made everything out of nothing, but the nothingness shows through.
    -- Paul Valery

Attachment: pgpib1K3se0uS.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]