[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: X crash with unplugged wireless mouse



On Wed, 2007-09-12 at 18:29 +0100, Federico Marziali wrote:
Hello everyone!
I run FC6 on an Acer TM8003 Laptop. I bought a cordless Logitech V450
Wireless mouse and added the following specific lines in my xorg.conf
(config thanks to the Gentoo wiki
http://gentoo-wiki.com/HOWTO_Advanced_Mouse/Individual_Configurations
):

Section "ServerLayout"
...............
...............
	InputDevice "V450" "AlwaysCore"
EndSection

Section "InputDevice"
	Identifier "V450"
	Driver "evdev"
	Option "Device" "/dev/input/event3"
	Option "HWHEELRelativeAxisButtons" "7 6"
EndSection

I have added also the following line, that I thought should help in
case I started the machine forgetting to plug the mouse radio receiver
into a USB port (i.e. X can't find the V450):

Section "Serverflags"
	Option "AllowMouseOpenFail" "true"
EndSection

The mouse works perfectly (also the horizontal scrolling), but
everything goes wrong if I forget to plug the wireless receiver before
the Linux kernel is loaded. In such a case, immediately after the
loading the driver "udev", the screen goes completely blank and apart
from a spare hard drive activity nothing happens; the usual fedora
bootstrap logo with the sequence of loading stuff does not appear and
despite all keys combinations I tried it looks like there is no way to
interact with the machine. The point is that Linux itself seems not to
be frozen, since pressing the power button (not leaving it pressed for
4 sec, which actually cuts the power, just pressing it "shortly")
starts the shutdown sequence, which takes a while and I presume goes
fine (nothing in var/spool/mail/root... so everything ok?!!)
So I guess the problem is that X does not load because of evdev does
not find the wireless receiver? Is the AllowMouseOpenFail option not
working?
Is there a way to have X start even if the cordless mouse is not plugged in?

I'm a newbie, so I could not think of anything better than look into
/var/log/messages and what I actually found are the gdm messages:
gdm_slave_xioerror_handler: Fatal X error - Restarting :0

And after 3 of them:
Sep 12 17:49:33 localhost gdm[3128]: gdm_slave_xioerror_handler: Fatal
X error - Restarting :0
Sep 12 17:49:33 localhost gdm[2989]: deal_with_x_crashes: Running the
XKeepsCrashing script
Sep 12 17:49:34 localhost gpm[2606]: *** info [client.c(137)]:
Sep 12 17:49:34 localhost gpm[2606]: Connecting at fd 2

Then I press the shutdown button and the messages are:
Sep 12 17:50:53 localhost shutdown[3275]: shutting down for system halt
Sep 12 17:50:53 localhost gdm[2989]: Failed to start X server several
times in a short time period; disabling
display :0
Sep 12 17:50:53 localhost gpm[2606]: *** info [client.c(275)]:
Sep 12 17:50:53 localhost gpm[2606]: Request on 2 (console 9)
Sep 12 17:50:53 localhost gpm[2606]: *** info [client.c(284)]:
Sep 12 17:50:53 localhost gpm[2606]: Closing
<more shutdown messages cut>

I apologise for the length of the post, any help is appreciated.

Fede

Your system is coming up, but X isn't.  So boot to runlevel 3 (a setting near the top of the /etc/inittab file), log in, run "tail -f /var/log/messages" so you can watch what's logged, and plug in the USB receiver.  If no errors occur then start X manually ("startx").  If X crashes you should land back at a console prompt (after all the errors fly by!).

-- Mark C. Allman, PMP
-- Allman Professional Consulting, Inc.
-- www.allmanpc.com, 617-947-4263
BusinessMsg -- the secure, managed, J2EE/AJAX Enterprise IM/IC solution.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]