[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: has no permission to open the device



I have tried loggin in as root and burning a CD, but the same problem 
persists. Also, when I sudo k3b &, I get the message that growisofs cannot be 
found, but it is right there in /usr/bin along with all of the other ones.

The permissions and ownership of cdrecord (actually a link to wodim) are:

lrwxrwxrwx 1 root root 5 2007-06-21 17:50 /usr/bin/cdrecord -> wodim

I don't know how to make cdrecord an SUID root program, unless it means to 
change the ownership with chown. I have never changed any of these 
ownerships.

Previous versions of k3b warned that some permissions and/or ownerships of 
some programs be changed, but way back in Fedora3 or 4, I tried that and the 
result was that burning became impossible. Since then, I have always ignored 
those messages and burning worked like a charm.

Now, with the change to wodim instead of cdrecord, these messages no longer 
appear, but since recently, burning is no longer possible. A whole stack of 
blank CDs have been ruined: writing begins and then the session is closed, 
but nothing is written.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]