[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 moto4lin problem



Adalbert Prokop wrote:
Paul Erickson wrote on Sunday 16 September 2007:

I have just installed moto4lin to use with my RAZR V3t, but keep
getting an unable to connect error.

;-) Your name suggests another type of mobile phone. <SCNR>

When I first launch the application I get:

[info] Phone is unpluged. Please connect it

I have a V220 which works with moto4lin. V3 may behave differently.

The problem is: this phone appears under two different USB IDs. After switching from AT to P2K mode the USB-ID changes from 22b8:4902 to 22b8:4901. If udev is quicker than moto4lin reacts - all things are fine. If it is not, then moto4lin tries to read from the old device file which does not exist any more and produces errors. It happens to me very often. In this case, simply close moto4lin and restart it. The phone stays in P2K mode and you should be able to connect to it now.

Another problem: access rights. I don't know if SElinux causes problems here, because I've deactivated it. The device files created for my phone are ttyACM* and are not accessible to "normal" users. I had to create an udev config file /etc/udev/rules.d/99-motorola.rules with the following rules

KERNEL=="ttyACM*", GROUP="users", MODE="0660"

BUS=="usb", SYSFS{idProduct}=="4902", SYSFS{idVendor}=="22b8", RUN \ += "/bin/chmod 660 $env{DEVNAME}" BUS=="usb", SYSFS{idProduct}=="4902", SYSFS{idVendor}=="22b8", RUN \ += "/bin/chgrp users $env{DEVNAME}" BUS=="usb", SYSFS{idProduct}=="4901", SYSFS{idVendor}=="22b8", RUN \ += "/bin/chmod 660 $env{DEVNAME}" BUS=="usb", SYSFS{idProduct}=="4901", SYSFS{idVendor}=="22b8", RUN \ += "/bin/chgrp users $env{DEVNAME}"

(merge the lines ending with "\" with the following one)

Also I am attempting to do this as a user, rather than root. I have not
tried as root yet.

You should at least try to run it as root to rule out problem with access rights.

The settings I've made in my moto4line are:

ACM Device:     /dev/ttyACM0
AT Vendor ID:   22b8
AT Product ID:  4902
P2K Vendor ID:  22b8
P2K Product ID: 4901

[ ] Detach kernel driver
[ ] Auto Connect to device

Thanks very much for the reply. I tried as root, and no joy. I created the file you mentioned, and now when I start up
the application I get:

[info] Phone pluged as P2K
[info] Phone pluged as AT
Try to connect
[error] Unable to connect

Any other thoughts?


--
----------------------------------------------------------------
cheers, Paul - VA7NT - email: va7nt telus net

"Those who hear not the music, think the dancers mad."

“Tolerance becomes a crime when applied to evil.” - Thomas Mann

"That state which separates it's warriors from it's scholars will have it's thinking done by cowards and fighting done by fools" - Thucydides - The Pelopenisia
"The Malice of the wicked is reinforced by the weakness of the virtuous." - Churchill



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]