[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Qt meta object compiler missing



Phil Meyer wrote:

> Peter Lesterhuis wrote:
>> Hi,
>> I have a problem compiling the program "sailcut"
>> (http://www.sailcut.com/Sailcut_CAD).
>> When I issue the command "./configure" I get the this message:
>>
>> ...
>> checking for moc... not found
>> configure: error: No Qt meta object compiler (moc) found!
>> Please check whether you installed Qt correctly.
>> You need to have a running moc binary.
>> configure tried to run  and the test didn't
>> succeed. If configure shouldn't have tried this one, set
>> the environment variable MOC to the right one before running
>> configure.
>>
>> I have qt and qt-devel installed:
>> ]# rpm -qa | grep qt
>> dbus-qt-0.70-1.fc7
>> avahi-qt3-0.6.17-1.fc7
>> qt-3.3.8-6.fc7
>> qt-devel-3.3.8-6.fc7
>>
>> Does anybody have a clue?

> There are a number of QT based packages that have not specified how to
> find moc if its not in the user's path.  The easiest method is to put it
> in your path, ie:
> 
> $ export $PATH=${PATH}:/usr/lib/qt-3.3/bin
> Now try ./configure again
> 
> If it fails to find the libraries, you may also have to add:
> $ ./configure --qtdir=/usr/lib/qt-3.3

source /etc/profile.d/qt.sh
should set all that up for you (adding to PATH, defining QTDIR, QTINC,
QTLIB).

-- Rex


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]