[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Qt meta object compiler missing




Peter Lesterhuis wrote:
> Hi,
> I have a problem compiling the program "sailcut" > (http://www.sailcut.com/Sailcut_CAD).
> When I issue the command "./configure" I get the this message:
>
> ...
> checking for moc... not found
> configure: error: No Qt meta object compiler (moc) found!
> Please check whether you installed Qt correctly.
> You need to have a running moc binary.
> configure tried to run  and the test didn't
> succeed. If configure shouldn't have tried this one, set
> the environment variable MOC to the right one before running
> configure.
>
> I have qt and qt-devel installed:
> ]# rpm -qa | grep qt
> dbus-qt-0.70-1.fc7
> avahi-qt3-0.6.17-1.fc7
> qt-3.3.8-6.fc7
> qt-devel-3.3.8-6.fc7
>
> Does anybody have a clue?
> Peter
>

There are a number of QT based packages that have not specified how to find moc if its not in the user's path. The easiest method is to put it in your path, ie:

$ export $PATH=${PATH}:/usr/lib/qt-3.3/bin

Now try ./configure again

If it fails to find the libraries, you may also have to add:

$ ./configure --qtdir=/usr/lib/qt-3.3
Thanks for your help. The first method worked.
Now I'm stuck during the "make".
$ make
make  all-recursive
make[1]: Entering directory `/home/peter/downloads/sailcut-1.3.0'
Making all in icons
make[2]: Entering directory `/home/peter/downloads/sailcut-1.3.0/icons'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/peter/downloads/sailcut-1.3.0/icons'
Making all in src
make[2]: Entering directory `/home/peter/downloads/sailcut-1.3.0/src'
/usr/lib/qt-3.3/bin/uic -o ui_formhulldefbase.h formhulldefbase.ui
uic: File generated with too recent version of Qt Designer (4.0 vs. 3.3.8)
make[2]: *** [ui_formhulldefbase.h] Error 1
make[2]: Leaving directory `/home/peter/downloads/sailcut-1.3.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/peter/downloads/sailcut-1.3.0'
make: *** [all] Error 2

How should I understand this? Is the message complaining of a too recent version of qt-designer? Or does it need a more recent version?
]$ rpm -qa | grep qt
qt4-4.3.1-3.fc7
dbus-qt-0.70-1.fc7
qt-designer-3.3.8-6.fc7
qt4-x11-4.3.1-3.fc7
avahi-qt3-0.6.17-1.fc7
qt4-devel-4.3.1-3.fc7
qt-3.3.8-6.fc7
qt-devel-3.3.8-6.fc7

Peter


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]