[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems with Xorg restarting after KDE logout



Martin Marques wrote:
> I've experienced problems with logouts (any user) on my FC6. Basically,
> X crashes and I end up in a terminal. From there I can start X again
> without a problem but on logout I don't get the kdm login screen.
> 
> Looking at the logs I found something very peculiar:
> 
> When starting X and kdm ffom boot I see this in the Xorg.0.log:
> 
> (II) SAVAGE(0): [drm] bpp: 32 depth: 24
> (II) SAVAGE(0): [drm] Sarea 2200+284: 2484
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is -1, (No such device or address)
> drmOpenDevice: open result is -1, (No such device or address)
> drmOpenDevice: Open failed
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is -1, (No such device or address)
> drmOpenDevice: open result is -1, (No such device or address)
> drmOpenDevice: Open failed
> drmOpenByBusid: Searching for BusID pci:0000:01:00.0
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is 6, (OK)
> drmOpenByBusid: drmOpenMinor returns 6
> drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
> (II) SAVAGE(0): [drm] loaded kernel module for "savage" driver
> (II) SAVAGE(0): [drm] DRM interface version 1.3
> (II) SAVAGE(0): [drm] created "savage" driver at busid "pci:0000:01:00.0"
> (II) SAVAGE(0): [drm] added 8192 byte SAREA at 0xe00fd000
> (II) SAVAGE(0): [drm] mapped SAREA 0xe00fd000 to 0xb7f11000
> (II) SAVAGE(0): [drm] framebuffer handle = 0xd0000000
> (II) SAVAGE(0): [drm] added 1 reserved context for kernel
> (II) SAVAGE(0): [agp] Mode 0x1f000201 [AGP 0x1106/0x3116; Card
> 0x5333/0x8d04]
> 
> But when I logout and X has to restart I get this:
> 
> (II) SAVAGE(0): [drm] bpp: 32 depth: 24
> (II) SAVAGE(0): [drm] Sarea 2200+284: 2484
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is 6, (OK)
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is 6, (OK)
> drmOpenByBusid: Searching for BusID pci:0000:01:00.0
> drmOpenDevice: node name is /dev/dri/card0
> drmOpenDevice: open result is 6, (OK)
> drmOpenByBusid: drmOpenMinor returns 6
> drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
> (II) SAVAGE(0): [drm] DRM interface version 1.0
> (II) SAVAGE(0): [drm] drmSetBusid failed (6, pci:0000:01:00.0),
> Permission denied
> (EE) SAVAGE(0): [drm] DRIScreenInit failed.  Disabling DRI.
> (EE) SAVAGE(0): DRI isn't enabled
> 
> Now, two things come up from here:
> 
> 1) In the first boot it's using version 1.3 of DRM interface, while at
> restart it uses 1.0. What can be wrong?
> 2) There seems to be a permission error when trying to access the SAVAGE
> card at the busid specified.
> 
> Any clues?

Maybe following the procedures in this link will help?

http://dri.freedesktop.org/wiki/DriTroubleshooting

> 


-- 
Greener's Law:
	Never argue with a man who buys ink by the barrel.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]