[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: New grub problem on FC7 - suggestions anyone?



William W. Austin wrote:
...
New problem: grub no longer boots the system. I tried again after full power-down. Same result. Eventually after the usual HW/bios startup messages I get a black screen, and the word GRUB appears. Then several seconds another GRUB is added. I let this run while I ran an errand - and it continued that way "GRUB GRUB ... etc" for over an hour. There were _no_ error messages. I was able to reboot using the rescue CD, and did full fsck's of all drives. Luckily I have another working system here with a burner and I created a boot CD so that I can get the machine to boot.

After I got the machine to boot using a boot cd, I did a grub-install, but the results are different - I get Error 17 (which is cannot mount selected partition).
Is that error during the grub-install, or while trying to boot ?

{As on off-side, I am using that kernel on i386/athlon and core2duo for the last week OK}.

After grub-install do you get to the grub select/boot screen during boot ?

Do you have multiple physical drives ?
Maybe post fdisk -l, and /boot/grub/grub.conf

Which kernel is the previous kernel you had been running ?

You might like to make a grub boot floppy/cd. Then you enter commands like:
root (hd0,0)
kernel /vm {tab}
inited /in {tab}
boot

This would prove that the partition numbers are OK.
Does you /boot/grub/device.map exist and contain something like ? :
# this device map was generated by anaconda
(hd0)     /dev/sda

DaveT.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]