[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: php-gd depency problem



On 29/09/2007, D.Terweij | NTG-Support <d terweij nettuning net> wrote:
>
> [root v234 named]# yum install php-gd
> Setting up Install Process
> Parsing package install arguments
> Resolving Dependencies
> --> Running transaction check
> ---> Package php-gd.i386 0:5.2.2-3 set to be updated
> --> Processing Dependency: php-common = 5.2.2-3 for package: php-gd
> --> Finished Dependency Resolution
> Error: Missing Dependency: php-common = 5.2.2-3 is needed by package php-gd
> [root v234 named]# rpm -qa | grep php
> php-common-5.2.4-1.fc7
> php-5.2.4-1.fc7
> php-pdo-5.2.4-1.fc7
> php-cli-5.2.4-1.fc7
> php-mbstring-5.2.4-1.fc7
> php-pear-1.5.0-3
> phpMyAdmin-2.11.0-1.fc7
> php-mysql-5.2.4-1.fc7
> [root v234 named]#
>
> Could someone fix that?

Where did you get the PHP 5.2.4 update? In [updates-testing]? I cannot
find it in any of the repositories and not in the Fedora Updates
System either. Which repos do you use? The 5.2.4-1.fc7 build of PHP in
koji (= the Fedora 7 Build System) contains also a newer php-gd
package which requires php-common = 5.2.4-1.fc7 whereas in your update
attempt yum complains about the old php-gd package from stock Fedora
7.

Anyway, such a problem has not been found by the broken deps checker
either, which is run regularly for Fedora 7, too, and reports problems
to the package maintainers. Hence I believe there has never been an
official Fedora 7 Update for the prepared PHP 5.2.4 build yet.

http://bugzilla.redhat.com -- Product "Fedora", Component "php" --
would be the place where to report bugs with the packages.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]