[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Why radeontool?





Doug Wyatt wrote:

>Doug Wyatt <dwyatt sunflower com> writes:
>> Yesterday, when I ran 'yum update' on F7 I got two packages
>> installed for which I can't find a reason (see yum log
>> excerpt below).
>>
>> The two new packages are vbetool and radeontool.  From
>> what I can find, both used to be part of pm-utils.
>>
>> I really don't know about vbetool, maybe it's needed, but
>> radeontool is described as:
>>    "radeontool is a hack to save some battery on an
>>     ATI Radeon Mobility graphics chip. Radeontool can
>>     turn off and on the backlight and external video
>>     output."
>>
>> But, my platform is a desktop, not a laptop, with a GeForce
>> 6800 GT video card.
>>
>> Using yumex, I tried uninstalling radeontool to see what
>> depended on it; there were nearly 200 of them and pretty
>> much none of those were optional. They included most of
>> the OpenOffice pkgs, Control-Center and system-config-*,
>> for example.
>>
>> Can anyone explain, or even speculate, why radeontool?
>>
>
Jason L Tibbitts III <tibbs math uh edu> wrote:
> It (and vbetool) were split out of pm-utils.
>

If I assume that you saw that I noted this, myself, then
may I assume that you imply that radeontool became a
dependency simply because its parent package was one, and
not because it's actually needed?

Is this also because RPM is blind to hardware, beyond CPU
architecture?

- DAW

Karl Larsen wrote:
I use the theory that those who are in charge of updates do a good job. I back this up with the fact that F7 had so many problems I wound up writing bug reports. But as the updates started to arrive first one and then another problem would disappear. Now I can't find a problem except one. My Palm Pilot can't work with F7. Every thing else is great.

Last week I got the updates to nVidia that would not work. I just said OK. This week we got a new kernel and the nVidia updates worked fine now. So I can't understand your problem unless you changed something that has yum messed up.


This thread was about me asking about a new package that didn't
make sense to me.  My interest, here, was to try to learn a bit
more about package management how's and why's.  In this case, I
am not indicating that I have a problem, just a question.  And,
I don't start or stop with a posting to this list.  I also look
for answers in other places.  e.g. I've found some information
on the pm-utils split over on the Fedora Developers list, for
example, that helps me understand a little more.

On another thread, I indicated that I had received postings from
the package announcement list indicating that the '7-85' kernel was
released, but my attempts to update did not show that new kernel
and visiting a few repositories, I also did not find that kernel.
My expectation was that an announcement wouldn't be sent until
the package was placed into the repositories.  Perhaps I was wrong,
or perhaps there was a last-minute problem with that release.

That kernel and a number of other updates became available and I
installed them, as indicated in the first posting in this thread.
And now, a new kernel update, '9-91' is available, and I've
installed that.  My Yum setup is fine.

I'm on this list to learn a bit, likely about problems I encounter,
sometimes just about questions I have, and if I should actually
think I have something useful to contribute, then I'll do that too,
though I'm pretty low on the learning curve for Linux.

Regards,
DAW







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]