YUM failures

don vogt donvogt2001 at yahoo.com
Sat Feb 2 20:08:35 UTC 2008

> # yum update
> Setting up Update Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package rhythmbox.i386 0:0.10.1-7.fc7 set to be
> ---> Package nautilus-sendto.i386 0:0.12-1.fc7 set
to be updated
> ---> Package redhat-menus.noarch 0:8.9.10-4.fc7 set
to be updated
> ---> Package pulseaudio-lib.i386 0:0.9.6-2.fc7.1 set
to be updated
> ...
> ---> Package vim-common.i386 2:7.1.211-1.fc7 set to
be updated
> ---> Package claws-mail.i386 0:3.2.0-3.fc7 set to be
> ---> Package glew.i386 0:1.4.0-5.fc7 set to be
> --> Finished Dependency Resolution
> Error: Missing Dependency: xine-lib = 1.1.7 is
needed by package
> xine-lib-extras-nonfree

I had pretty much the same -problem.
 I had livna disabled in the repo file.
 I think what I did was the following.
 I ran
 yum update --excludepackage=xine-lib
 To get all the other stuff out of the way.
Then I ran
 yum --enablerepo=livna update xine-lib
and yum kept it all straight with no errors.
 I think that xine-lib is a fedora package and
xine-lib-extras-nonfree is a livna package and you
have to give yum a chance to see bothe repos.
Hope that helps.

More information about the fedora-list mailing list