Another ssh problem-SOLVED

Aaron Konstam akonstam at
Tue Feb 5 11:12:11 UTC 2008

On Tue, 2008-02-05 at 10:07 +1100, Cameron Simpson wrote:
> On 04Feb2008 16:05, Aaron Konstam <akonstam at> wrote:
> | I have 2 machines that are essentially F7 machines. From machine A I
> | cannot sftp to machine B as myself. But sftp does work to Machine B if I
> | am root. 
> | How can this be explained?
> | 
> | To be honest I have to reveal that Machine A is an olpc XO machine
> | without passwds on any user including root. Machine B is my f7 laptop.
> You would need to examine /var/log/secure on machineB for diagnostic
> errors. I would guess directory or file permission problems.
Your suggestion solved the problem and showed that I was nnot thinking
straight. The answer was my laptop did not have a user olpc.
When I sftp-ed to akonstam at it worked.
I felt pretty stupid not to have not caught that. Thanks for setting me
on the road to the solution.

With reasonable men I will reason; with humane men I will plead; but to
tyrants I will give no quarter. -- William Lloyd Garrison
Aaron Konstam telephone: (210) 656-0355 e-mail: akonstam at

More information about the fedora-list mailing list