Tux Typing broken

Simon Andrews simon.andrews at bbsrc.ac.uk
Fri Feb 8 12:10:35 UTC 2008

Da Rock wrote:
> I'm trying to get Tux Typing to work for her, but I can't 
> get any of the games in it to work. I get to the startup 
> screen, but as soon as I select a game for her to play it 
> dies and goes back to desktop. As I have requested in another 
> thread, some more info regarding gnome, X, or the program 
> would be useful, but I can't find anything in the logs, 
> messages and so forth. If someone could help me find the right 
> logs, then I may be able to solve this.
> This is the first time I have had to do this, so what is the 
> process involved with reporting this bug?

I tried this on one of our workstations and it failed for me too in 
exactly the same way.

Running tuxtype from the console I can see that it actually segfaults. 
I tried running it under the debugger and there are lots of errors 
coming from libraries related to the sound system (libvorbis, libasound, 
libogg).  I don't have all the debuginfo packages installed though so I 
don't have a really useful backtrace.

I'm running this on a fully up to date F8 x86_64 machine, using the 64 
bit version of tuxtype.

Hopefully since this isn't just you it should be fairly easy for the 
developer to reproduce.

To report a bug simply go to bugzilla.redhat.com.  Create an account for 
yourself using the "New account" button at the top.  I've checked and 
there isn't a bug open for this issue so you'll need to make a new bug 
report.  You want to assign it to Fedora > 8 > tuxtype2, and just answer 
the questions it asks.

Once you've reported the bug post the bug number here and I'll add a 
note saying that it fails for me too.


More information about the fedora-list mailing list