total frustration with sound in Fedora 8

Mark C. Allman mcallman at
Fri Feb 8 14:40:56 UTC 2008

On Fri, 2008-02-08 at 21:09 +1100, Danny Yee wrote:
> I must have wasted three or four hours reading various web pages about
> Fedora 8 sound problems and trying various fixes -- I keep finding
> "solutions" that work for some applications but not others, or work
> for a while and then stop working for no obvious reason.
> * I can't use totem or rhythmbox as they crash, killing firefox and
>   starting gnome-screensaver (and eventually killing by X session)
>   [I'm not using gnome or kde]
> * I've managed to get kaffeine to work, but it never keeps on working
> Things I've tried:
> * making sure avahi-daemon and ConsoleKit are running (this was my first
>   "aha, that's solved it", but now restarting these does nothing)
> * running kaffeine as root (I eventually settled on that as a "good
>   enough" solution, but now that doesn't work)
> * changing files like /etc/security/console.perms.d/60-sound.perms
>   following various arcane instructions on web pages
>   (this never seemed to do anything)
> * restarting pulseaudio by hand (again following instructions)
> 	/usr/bin/pulseaudio -k
> 	rm /tmp/pulse-$USER/pid
> 	/usr/bin/pulseaudio -D
>   (this never seemed to do anything useful either)
> * removing and/or reinstalling packages such as alsa-plugins-pulseaudio
>   (either no effect or toggles the YouTube versus CD functionality)
> * extensive Google searches and perusal of the suggestions they find
> Current situation: sound works in e.g. YouTube but I can't play audio CDs 
> -- kaffeine crashes, and totem and rhythmbox crash even worse (taking 
>    firefox with them)
> If I actually used sound in any serious way I'd have gone back
> to Fedora 7 or switched to another distribution weeks ago.  As it
> is it's annoying the hell out of me because I'm reading a book on
> psychoacoustics and I want to listen to the accompanying audio CD.
> Yes, I should file something in bugzilla, but I don't even know which
> package needs fixing.
> Danny.
>   ---------------------------------------------------------
> - over nine hundred book reviews
> - civil liberties, travel tales, blog
>   ---------------------------------------------------------
Same here.  I was listening to the Shuttle countdown yesterday and it
suddenly quit playing.  No error messages, just no sound!  The NASA TV
page launched the RealAudio plugin.  It worked for awhile, then nothing.
It's not that it quit--it's that there's no feedback to try to resolve
the problem!

Alsa keeps telling me that there are no sound cards detected.  No other
error messages.  I see cards under /proc/asound, and it all looks like
there's something there:
    [mcallman at prez BusinessMsg]$ ls /proc/asound
    card0 cards devices hwdep Intel modules oss pcm seq timers version
    [mcallman at prez BusinessMsg]$ cat /proc/asound/cards
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xdfffc000 irq 21

-- Mark C. Allman, PMP
-- Allman Professional Consulting, Inc.
--, 617-947-4263

BusinessMsg -- the secure, managed, J2EE/AJAX Enterprise IM/IC solution

More information about the fedora-list mailing list